summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-08-11 02:51:25 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-08-11 02:51:25 +0000
commit73e18a3e870a284ac2224f2a1f0c6a3ef9916583 (patch)
treeb8d53255c94d56f3704ffaa1f6bc6d6496d09d64 /dev-python/python-heatclient
parentupdating python-novaclient (diff)
downloadgentoo-2-73e18a3e870a284ac2224f2a1f0c6a3ef9916583.tar.gz
gentoo-2-73e18a3e870a284ac2224f2a1f0c6a3ef9916583.tar.bz2
gentoo-2-73e18a3e870a284ac2224f2a1f0c6a3ef9916583.zip
just updating heatclient, nothing to see here
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/python-heatclient')
-rw-r--r--dev-python/python-heatclient/ChangeLog8
-rw-r--r--dev-python/python-heatclient/python-heatclient-0.2.4.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-python/python-heatclient/ChangeLog b/dev-python/python-heatclient/ChangeLog
index 0659f3cdc33a..38e5dca1798e 100644
--- a/dev-python/python-heatclient/ChangeLog
+++ b/dev-python/python-heatclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-heatclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-heatclient/ChangeLog,v 1.1 2013/06/09 02:02:39 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-heatclient/ChangeLog,v 1.2 2013/08/11 02:51:25 prometheanfire Exp $
+
+*python-heatclient-0.2.4 (11 Aug 2013)
+
+ 11 Aug 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +python-heatclient-0.2.4.ebuild:
+ just updating heatclient, nothing to see here
*python-heatclient-9999 (09 Jun 2013)
*python-heatclient-0.2.2 (09 Jun 2013)
diff --git a/dev-python/python-heatclient/python-heatclient-0.2.4.ebuild b/dev-python/python-heatclient/python-heatclient-0.2.4.ebuild
new file mode 100644
index 000000000000..05d86dea6412
--- /dev/null
+++ b/dev-python/python-heatclient/python-heatclient-0.2.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-heatclient/python-heatclient-0.2.4.ebuild,v 1.1 2013/08/11 02:51:25 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a client library for Heat built on the Heat orchestration
+API."
+HOMEPAGE="https://github.com/openstack/python-heatclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mox[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-exclude[${PYTHON_USEDEP}]
+ dev-python/nosexcover
+ dev-python/nosehtmloutput[${PYTHON_USEDEP}]
+ dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
+ =dev-python/pep8-1.2
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-git-0.4[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/pbr-0.5.16[${PYTHON_USEDEP}]
+ <dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.6[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ <dev-python/python-keystoneclient-0.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+
+PATCHES=(
+)
+# "${FILESDIR}/0.2.3-CVE-2013-2104.patch"
+
+python_test() {
+ ${PYTHON} setup.py nosetests || die
+}