summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-12-03 14:21:08 +0000
committerIan Delaney <idella4@gentoo.org>2013-12-03 14:21:08 +0000
commitb1e101d77421eaf92677957d7d74f8f0ec222ab4 (patch)
treeadb9f972d90ca16e7b3be8d19c75a822fc060dbb /dev-python/python-heatclient
parentStable for amd64 wrt bug #491898 (diff)
downloadgentoo-2-b1e101d77421eaf92677957d7d74f8f0ec222ab4.tar.gz
gentoo-2-b1e101d77421eaf92677957d7d74f8f0ec222ab4.tar.bz2
gentoo-2-b1e101d77421eaf92677957d7d74f8f0ec222ab4.zip
fix to test phase, thx to Chicago for reporting flaw
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-heatclient')
-rw-r--r--dev-python/python-heatclient/ChangeLog5
-rw-r--r--dev-python/python-heatclient/python-heatclient-0.2.5.ebuild6
2 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/python-heatclient/ChangeLog b/dev-python/python-heatclient/ChangeLog
index 1ee252e8ef67..0a5642588e37 100644
--- a/dev-python/python-heatclient/ChangeLog
+++ b/dev-python/python-heatclient/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/python-heatclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-heatclient/ChangeLog,v 1.4 2013/10/23 16:26:24 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-heatclient/ChangeLog,v 1.5 2013/12/03 14:21:08 idella4 Exp $
+
+ 03 Dec 2013; Ian Delaney <idella4@gentoo.org> python-heatclient-0.2.5.ebuild:
+ fix to test phase, thx to Chicago for reporting flaw
*python-heatclient-0.2.5 (23 Oct 2013)
diff --git a/dev-python/python-heatclient/python-heatclient-0.2.5.ebuild b/dev-python/python-heatclient/python-heatclient-0.2.5.ebuild
index b5dbf8a693e0..8a0bd79639d9 100644
--- a/dev-python/python-heatclient/python-heatclient-0.2.5.ebuild
+++ b/dev-python/python-heatclient/python-heatclient-0.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-heatclient/python-heatclient-0.2.5.ebuild,v 1.1 2013/10/23 16:26:24 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-heatclient/python-heatclient-0.2.5.ebuild,v 1.2 2013/12/03 14:21:08 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -47,5 +47,7 @@ PATCHES=(
# "${FILESDIR}/0.2.3-CVE-2013-2104.patch"
python_test() {
- ${PYTHON} -m subunit.run discover -t ./ . || die
+ testr init
+ testr run || die "Tests failed under python2.7"
+ flake8 heatclient/tests || die "run over tests folder by flake8 yielded error"
}