summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-09 05:09:56 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-09 05:09:56 +0000
commit14f004dfd493b722f00b1843414c0cb4a4a3ab2b (patch)
treed88cb73f54deee2eb9d5d27f97b4200a806d71a6 /dev-python/rdflib
parentVersion bump. (diff)
downloadgentoo-2-14f004dfd493b722f00b1843414c0cb4a4a3ab2b.tar.gz
gentoo-2-14f004dfd493b722f00b1843414c0cb4a4a3ab2b.tar.bz2
gentoo-2-14f004dfd493b722f00b1843414c0cb4a4a3ab2b.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/rdflib')
-rw-r--r--dev-python/rdflib/ChangeLog7
-rw-r--r--dev-python/rdflib/rdflib-4.1.2.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-python/rdflib/ChangeLog b/dev-python/rdflib/ChangeLog
index 82dcb557a2aa..eed2e65efe02 100644
--- a/dev-python/rdflib/ChangeLog
+++ b/dev-python/rdflib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/rdflib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/ChangeLog,v 1.41 2014/04/22 09:23:00 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/ChangeLog,v 1.42 2014/05/09 05:09:56 patrick Exp $
+
+*rdflib-4.1.2 (09 May 2014)
+
+ 09 May 2014; Patrick Lauer <patrick@gentoo.org> +rdflib-4.1.2.ebuild:
+ Bump
*rdflib-4.1.1 (22 Apr 2014)
diff --git a/dev-python/rdflib/rdflib-4.1.2.ebuild b/dev-python/rdflib/rdflib-4.1.2.ebuild
new file mode 100644
index 000000000000..f7b7d9e4015d
--- /dev/null
+++ b/dev-python/rdflib/rdflib-4.1.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/rdflib-4.1.2.ebuild,v 1.1 2014/05/09 05:09:56 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_REQ_USE="sqlite?"
+DISTUTILS_NO_PARALLEL_BUILD=true
+# The usual required for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="RDF library containing a triple store and parser/serializer"
+HOMEPAGE="https://github.com/RDFLib/rdflib http://pypi.python.org/pypi/rdflib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="berkdb examples mysql redland sqlite test"
+
+RDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/html5lib[$(python_gen_usedep 'python2*')]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
+ mysql? ( dev-python/mysql-python[$(python_gen_usedep 'python2*')] )
+ redland? ( dev-libs/redland-bindings[python] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/sparql-wrapper[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.1-r1[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Upstream manufactured .pyc files which promptly break distutils' src_test
+ find -name "*.py[oc~]" -delete || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if python_is_python3; then
+ pushd "${BUILD_DIR}/src/" > /dev/null
+ "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
+ popd > /dev/null
+ else
+ "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}