summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-03-26 04:12:08 +0000
committerIan Delaney <idella4@gentoo.org>2015-03-26 04:12:08 +0000
commitf7f269a45a101c7896449bfcff68e799a1b7b4d9 (patch)
tree2030c1231b1b500a81b415bbabfeb642896c5968 /dev-python/routes
parentBump (diff)
downloadgentoo-2-f7f269a45a101c7896449bfcff68e799a1b7b4d9.tar.gz
gentoo-2-f7f269a45a101c7896449bfcff68e799a1b7b4d9.tar.bz2
gentoo-2-f7f269a45a101c7896449bfcff68e799a1b7b4d9.zip
bump; correct and update deps, rm IUSE doc and build / install since doc build fails in both prior and bumped versions
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/routes')
-rw-r--r--dev-python/routes/ChangeLog9
-rw-r--r--dev-python/routes/routes-1.12.3-r1.ebuild35
-rw-r--r--dev-python/routes/routes-1.13-r1.ebuild42
-rw-r--r--dev-python/routes/routes-2.1.ebuild53
4 files changed, 61 insertions, 78 deletions
diff --git a/dev-python/routes/ChangeLog b/dev-python/routes/ChangeLog
index 72a2cae404af..14896e43fd43 100644
--- a/dev-python/routes/ChangeLog
+++ b/dev-python/routes/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/routes
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/ChangeLog,v 1.25 2015/03/08 23:58:22 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/ChangeLog,v 1.26 2015/03/26 04:12:08 idella4 Exp $
+
+*routes-2.1 (26 Mar 2015)
+
+ 26 Mar 2015; Ian Delaney <idella4@gentoo.org> +routes-2.1.ebuild,
+ -routes-1.12.3-r1.ebuild, -routes-1.13-r1.ebuild:
+ bump; correct and update deps, rm IUSE doc and build / install since doc build
+ fails in both prior and bumped versions
08 Mar 2015; Pacho Ramos <pacho@gentoo.org> routes-2.0.ebuild:
x86 stable, bug 540290
diff --git a/dev-python/routes/routes-1.12.3-r1.ebuild b/dev-python/routes/routes-1.12.3-r1.ebuild
deleted file mode 100644
index 377cb75e5962..000000000000
--- a/dev-python/routes/routes-1.12.3-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/routes-1.12.3-r1.ebuild,v 1.3 2014/08/10 21:21:16 slyfox Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python2_{6,7} )
-
-inherit distutils-r1
-
-MY_PN="Routes"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A Python re-implementation of the Rails routes system for mapping URL's to Controllers/Actions"
-HOMEPAGE="http://routes.groovie.org http://pypi.python.org/pypi/Routes"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-python_install() {
- distutils-r1_python_install
-
- if use doc; then
- cd docs/_build/html
- docinto html
- cp -R [a-z]* _images _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
- fi
-}
diff --git a/dev-python/routes/routes-1.13-r1.ebuild b/dev-python/routes/routes-1.13-r1.ebuild
deleted file mode 100644
index b291a474b6a2..000000000000
--- a/dev-python/routes/routes-1.13-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/routes-1.13-r1.ebuild,v 1.4 2014/03/31 21:15:13 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} pypy pypy2_0 )
-
-inherit distutils-r1
-
-MY_PN="Routes"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A Python re-implementation of the Rails routes system for mapping URL's to Controllers/Actions"
-HOMEPAGE="http://routes.groovie.org http://pypi.python.org/pypi/Routes"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-# Note: although setup.py states that tests require webtest,
-# it isn't used anywhere.
-RDEPEND="dev-python/webob[${PYTHON_USEDEP}]
- dev-python/repoze-lru[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/routes/routes-2.1.ebuild b/dev-python/routes/routes-2.1.ebuild
new file mode 100644
index 000000000000..3c488f593df2
--- /dev/null
+++ b/dev-python/routes/routes-2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/routes-2.1.ebuild,v 1.1 2015/03/26 04:12:08 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="Routes"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python re-implementation of Rails routes system, mapping URL's to Controllers/Actions"
+HOMEPAGE="http://routes.groovie.org http://pypi.python.org/pypi/Routes"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND=">=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]
+ )"
+# It appears there's an epidemic of missing testsuites coming out of github. Restrict for now
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+# Comment out patch for tests for now
+#PATCHES=( "${FILESDIR}"/${PN}-2.0-setup.py.patch )
+
+# The doc build possibly never built. Just know that the doc builds in
+# neither the previous nor this
+# https://github.com/bbangert/routes/issues/42
+python_prepare_all() {
+ use test && DISTUTILS_IN_SOURCE_BUILD=1
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cp -r tests "${BUILD_DIR}" || die
+ if [[ ${EPYTHON} == python3* ]]; then
+ 2to3 -w --no-diffs "${BUILD_DIR}"/tests || die
+ fi
+
+ nosetests -w "${BUILD_DIR}"/tests || die "Tests fail with ${EPYTHON}"
+}