summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-26 18:30:00 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-26 18:30:00 +0000
commitf68500db83494837f1cfc17bbd0ab0e81880561a (patch)
treec2687162de5c629e1c1bcc6c5a918a87f913b1a8 /dev-python/setproctitle
parentVersion bump. (diff)
downloadgentoo-2-f68500db83494837f1cfc17bbd0ab0e81880561a.tar.gz
gentoo-2-f68500db83494837f1cfc17bbd0ab0e81880561a.tar.bz2
gentoo-2-f68500db83494837f1cfc17bbd0ab0e81880561a.zip
Version bump.
(Portage version: 2.2.0_alpha28_p32/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/setproctitle')
-rw-r--r--dev-python/setproctitle/ChangeLog8
-rw-r--r--dev-python/setproctitle/setproctitle-1.1.2.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-python/setproctitle/ChangeLog b/dev-python/setproctitle/ChangeLog
index aa43de1a2c8a..848c5599c9fd 100644
--- a/dev-python/setproctitle/ChangeLog
+++ b/dev-python/setproctitle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/setproctitle
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setproctitle/ChangeLog,v 1.7 2011/03/24 11:44:12 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setproctitle/ChangeLog,v 1.8 2011/03/26 18:30:00 arfrever Exp $
+
+*setproctitle-1.1.2 (26 Mar 2011)
+
+ 26 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +setproctitle-1.1.2.ebuild:
+ Version bump.
24 Mar 2011; Markos Chandras <hwoarang@gentoo.org> setproctitle-1.1.1.ebuild:
Stable on amd64 wrt bug #360203
diff --git a/dev-python/setproctitle/setproctitle-1.1.2.ebuild b/dev-python/setproctitle/setproctitle-1.1.2.ebuild
new file mode 100644
index 000000000000..4ee7bc4bc91b
--- /dev/null
+++ b/dev-python/setproctitle/setproctitle-1.1.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setproctitle/setproctitle-1.1.2.ebuild,v 1.1 2011/03/26 18:30:00 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils toolchain-funcs
+
+DESCRIPTION="Allow customization of the process title."
+HOMEPAGE="http://code.google.com/p/py-setproctitle/ http://pypi.python.org/pypi/setproctitle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DOCS="HISTORY README"
+
+src_prepare() {
+ python_copy_sources
+
+ conversion() {
+ [[ "${PYTHON_ABI}" == 2.* ]] && return
+ 2to3-${PYTHON_ABI} -w --no-diffs tests > /dev/null
+ }
+ python_execute_function \
+ --action-message 'Applying patches for $(python_get_implementation) $(python_get_version)' \
+ --failure-message 'Applying patches for $(python_get_implementation) $(python_get_version) failed' \
+ -s conversion
+}
+
+distutils_src_test_pre_hook() {
+ ln -fs pyrun-${PYTHON_ABI} tests/pyrun
+}
+
+src_test() {
+ build_pyrun() {
+ echo $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -I$(python_get_includedir) -o tests/pyrun-${PYTHON_ABI} tests/pyrun.c $(python_get_library -l)
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -I$(python_get_includedir) -o tests/pyrun-${PYTHON_ABI} tests/pyrun.c $(python_get_library -l)
+ }
+ python_execute_function -q -s build_pyrun
+
+ distutils_src_test
+}