summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-05-06 11:57:45 +0000
committerJustin Lecher <jlec@gentoo.org>2015-05-06 11:57:45 +0000
commit25dbcfbd6685b1262f0b9ae387de8d3906993e66 (patch)
tree42b759d5e81f67b6241ed2a3223b895bcbf58c2a /dev-python/six
parentFix bug 547990. Thanks to Daniel Campbell for testing. (diff)
downloadgentoo-2-25dbcfbd6685b1262f0b9ae387de8d3906993e66.tar.gz
gentoo-2-25dbcfbd6685b1262f0b9ae387de8d3906993e66.tar.bz2
gentoo-2-25dbcfbd6685b1262f0b9ae387de8d3906993e66.zip
Backport fix for windows only modules, bug #547928
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/ChangeLog8
-rw-r--r--dev-python/six/files/six-1.9.0-winreg.patch27
-rw-r--r--dev-python/six/metadata.xml8
-rw-r--r--dev-python/six/six-1.9.0-r1.ebuild41
-rw-r--r--dev-python/six/six-9999.ebuild27
5 files changed, 89 insertions, 22 deletions
diff --git a/dev-python/six/ChangeLog b/dev-python/six/ChangeLog
index 97fec5a5ebda..fae7d4f0f955 100644
--- a/dev-python/six/ChangeLog
+++ b/dev-python/six/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/six
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/six/ChangeLog,v 1.67 2015/04/08 08:05:18 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/six/ChangeLog,v 1.68 2015/05/06 11:57:45 jlec Exp $
+
+*six-1.9.0-r1 (06 May 2015)
+
+ 06 May 2015; Justin Lecher <jlec@gentoo.org> +files/six-1.9.0-winreg.patch,
+ +six-1.9.0-r1.ebuild, metadata.xml, six-9999.ebuild:
+ Backport fix for windows only modules, bug #547928
08 Apr 2015; Michał Górny <mgorny@gentoo.org> six-1.3.0.ebuild,
six-1.6.1.ebuild:
diff --git a/dev-python/six/files/six-1.9.0-winreg.patch b/dev-python/six/files/six-1.9.0-winreg.patch
new file mode 100644
index 000000000000..57e2074c8268
--- /dev/null
+++ b/dev-python/six/files/six-1.9.0-winreg.patch
@@ -0,0 +1,27 @@
+# HG changeset patch
+# User Benjamin Peterson <benjamin@python.org>
+# Date 1426865725 18000
+# Node ID c996ed1dc0064f45e691f1664d06001ae07fff00
+# Parent 7638872a6c760448ed8648d692c8eb702a29c361
+# Parent 24dc6a6f7384712152dd1e881c115fb4805be9ea
+Merged in mrossini/six (pull request #55)
+
+_winreg is added to the moves module under windows only
+
+diff --git a/six.py b/six.py
+--- a/six.py
++++ b/six.py
+@@ -298,8 +298,12 @@
+ MovedModule("urllib_robotparser", "robotparser", "urllib.robotparser"),
+ MovedModule("xmlrpc_client", "xmlrpclib", "xmlrpc.client"),
+ MovedModule("xmlrpc_server", "SimpleXMLRPCServer", "xmlrpc.server"),
+- MovedModule("winreg", "_winreg"),
+ ]
++#Add windows specific modules if needed
++if sys.platform in ('win32', 'cygwin'):
++ _moved_attributes += [
++ MovedModule("winreg", "_winreg"),
++ ]
+ for attr in _moved_attributes:
+ setattr(_MovedItems, attr.name, attr)
+ if isinstance(attr, MovedModule):
diff --git a/dev-python/six/metadata.xml b/dev-python/six/metadata.xml
index a2b6424e58e3..f3c6951bce50 100644
--- a/dev-python/six/metadata.xml
+++ b/dev-python/six/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>python</herd>
- <upstream>
- <remote-id type="pypi">six</remote-id>
- </upstream>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">six</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/six/six-1.9.0-r1.ebuild b/dev-python/six/six-1.9.0-r1.ebuild
new file mode 100644
index 000000000000..42c07ea156bb
--- /dev/null
+++ b/dev-python/six/six-1.9.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/six/six-1.9.0-r1.ebuild,v 1.1 2015/05/06 11:57:45 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2 and 3 compatibility library"
+HOMEPAGE="https://bitbucket.org/gutworth/six http://pypi.python.org/pypi/six"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-mapping.patch
+ "${FILESDIR}"/${P}-winreg.patch
+ )
+
+python_compile_all() {
+ use doc && emake -C documentation html
+}
+
+python_test() {
+ py.test -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( documentation/_build/html/ )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/six/six-9999.ebuild b/dev-python/six/six-9999.ebuild
index f44b2d8cf600..1322473187cd 100644
--- a/dev-python/six/six-9999.ebuild
+++ b/dev-python/six/six-9999.ebuild
@@ -1,35 +1,28 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/six/six-9999.ebuild,v 1.11 2014/11/25 01:07:11 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/six/six-9999.ebuild,v 1.12 2015/05/06 11:57:45 jlec Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
-#if LIVE
-EHG_REPO_URI="https://bitbucket.org/gutworth/six"
-
-inherit mercurial
-#endif
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
-inherit distutils-r1
+inherit distutils-r1 mercurial
DESCRIPTION="Python 2 and 3 compatibility library"
HOMEPAGE="https://bitbucket.org/gutworth/six http://pypi.python.org/pypi/six"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI=""
+EHG_REPO_URI="https://bitbucket.org/gutworth/six"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+KEYWORDS=""
IUSE="doc test"
-DEPEND="doc? ( dev-python/sphinx )
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-#if LIVE
-SRC_URI=
-KEYWORDS=
-#endif
-
python_compile_all() {
use doc && emake -C documentation html
}