summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-10-04 16:20:09 +0000
committerMichał Górny <mgorny@gentoo.org>2013-10-04 16:20:09 +0000
commitb162dbe9ffc1784295144520526c9c4f1c86503f (patch)
tree2eec331cbe7a827508e9920f6c4baeda3b8e8835 /dev-python/suds
parentAdd arm love. (diff)
downloadgentoo-2-b162dbe9ffc1784295144520526c9c4f1c86503f.tar.gz
gentoo-2-b162dbe9ffc1784295144520526c9c4f1c86503f.tar.bz2
gentoo-2-b162dbe9ffc1784295144520526c9c4f1c86503f.zip
Fix the distutils-r1 conversion.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/suds')
-rw-r--r--dev-python/suds/ChangeLog5
-rw-r--r--dev-python/suds/suds-0.4-r1.ebuild16
2 files changed, 9 insertions, 12 deletions
diff --git a/dev-python/suds/ChangeLog b/dev-python/suds/ChangeLog
index bb83ccca6062..d8c9614ad684 100644
--- a/dev-python/suds/ChangeLog
+++ b/dev-python/suds/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/suds
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/suds/ChangeLog,v 1.10 2013/09/12 05:14:18 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/suds/ChangeLog,v 1.11 2013/10/04 16:20:09 mgorny Exp $
+
+ 04 Oct 2013; Michał Górny <mgorny@gentoo.org> suds-0.4-r1.ebuild:
+ Fix the distutils-r1 conversion.
*suds-0.4-r1 (12 Sep 2013)
diff --git a/dev-python/suds/suds-0.4-r1.ebuild b/dev-python/suds/suds-0.4-r1.ebuild
index cec7c399d5b0..1c3f35075b82 100644
--- a/dev-python/suds/suds-0.4-r1.ebuild
+++ b/dev-python/suds/suds-0.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/suds/suds-0.4-r1.ebuild,v 1.1 2013/09/12 05:14:18 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/suds/suds-0.4-r1.ebuild,v 1.2 2013/10/04 16:20:09 mgorny Exp $
EAPI="5"
PYTHON_COMPAT=( python2_6 python2_7 )
@@ -20,19 +20,13 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/epydoc[${PYTHON_USEDEP}] )"
RDEPEND=""
-python_compile() {
- distutils-r1_python_compile
-
+python_compile_all() {
if use doc; then
- einfo "Generation of documentation"
- epydoc -n "Suds - ${DESCRIPTION}" -o doc suds || die "Generation of documentation failed"
+ epydoc -n "Suds - ${DESCRIPTION}" -o doc suds || die
fi
}
-python_install() {
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
distutils-r1_python_install_all
-
- if use doc; then
- dohtml -r doc/* || die "Installation of documentation failed"
- fi
}