summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-11-30 04:06:57 +0000
committerIan Delaney <idella4@gentoo.org>2014-11-30 04:06:57 +0000
commit8ab7a3225d2d7594355489a6299c88107fc08ff5 (patch)
treef54bdd76d9d29033be194bf07b189b749a8256d2 /dev-python/testfixtures
parentebuild written by me, new dep to testfixtures (diff)
downloadgentoo-2-8ab7a3225d2d7594355489a6299c88107fc08ff5.tar.gz
gentoo-2-8ab7a3225d2d7594355489a6299c88107fc08ff5.tar.bz2
gentoo-2-8ab7a3225d2d7594355489a6299c88107fc08ff5.zip
bump; clean old python impl, add py3.4, update deps, switch from patch to sed statements (lighter weight and easier maint.) to fix doc build, fixes Bug #530610
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/ChangeLog10
-rw-r--r--dev-python/testfixtures/testfixtures-3.0.0.ebuild4
-rw-r--r--dev-python/testfixtures/testfixtures-4.1.1.ebuild55
3 files changed, 66 insertions, 3 deletions
diff --git a/dev-python/testfixtures/ChangeLog b/dev-python/testfixtures/ChangeLog
index 8d804a35e224..7f27533c7b1f 100644
--- a/dev-python/testfixtures/ChangeLog
+++ b/dev-python/testfixtures/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/testfixtures
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testfixtures/ChangeLog,v 1.8 2014/06/30 08:18:54 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testfixtures/ChangeLog,v 1.9 2014/11/30 04:06:57 idella4 Exp $
+
+*testfixtures-4.1.1 (30 Nov 2014)
+
+ 30 Nov 2014; Ian Delaney <idella4@gentoo.org> +testfixtures-4.1.1.ebuild,
+ testfixtures-3.0.0.ebuild:
+ bump; clean old python impl, add py3.4, update deps, switch from patch to sed
+ statements (lighter weight and easier maint.) to fix doc build, fixes Bug
+ #530610
30 Jun 2014; Ian Delaney <idella4@gentoo.org> +files/docbuild.patch,
-files/testfixtures-2.3.4-adjust_tests.patch, -testfixtures-2.3.4.ebuild,
diff --git a/dev-python/testfixtures/testfixtures-3.0.0.ebuild b/dev-python/testfixtures/testfixtures-3.0.0.ebuild
index f3b966fd0519..b26d5b8e0a4c 100644
--- a/dev-python/testfixtures/testfixtures-3.0.0.ebuild
+++ b/dev-python/testfixtures/testfixtures-3.0.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testfixtures/testfixtures-3.0.0.ebuild,v 1.4 2014/06/30 08:18:54 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testfixtures/testfixtures-3.0.0.ebuild,v 1.5 2014/11/30 04:06:57 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
inherit distutils-r1
diff --git a/dev-python/testfixtures/testfixtures-4.1.1.ebuild b/dev-python/testfixtures/testfixtures-4.1.1.ebuild
new file mode 100644
index 000000000000..bdbdf512ec40
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-4.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testfixtures/testfixtures-4.1.1.ebuild,v 1.1 2014/11/30 04:06:57 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="http://pypi.python.org/pypi/testfixtures/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pkginfo[${PYTHON_USEDEP}]' python2_7 pypy ) )
+ test? ( dev-python/manuel[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-cover3[${PYTHON_USEDEP}]
+ dev-python/nose_fixes[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ )"
+
+python_prepare_all() {
+ # Makefile comes set pointing at a wrong location
+ sed -e 's:../bin/sphinx-build:/usr/bin/sphinx-build:' -i docs/Makefile || die
+ # Prevent un-needed download during build, fix Makefile for doc build
+ sed -e '/'sphinx.ext.intersphinx'/d' -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_prepare() {
+ # remove test that tests the stripped zope-component test_components.ComponentsTests
+ rm -f testfixtures/tests/test_components.py || die
+
+ distutils-r1_python_prepare
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests ${PN}/tests || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}