summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-09-17 18:21:08 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-09-17 18:21:08 +0000
commit868fb04d7ca86b97681f7646ebc507fb6e286dd1 (patch)
treeffbba9d88bd6939608b33ca59e03b1b19c02d856 /dev-python/testtools
parentVersion bump wrt bug #485060. Remove old. (diff)
downloadgentoo-2-868fb04d7ca86b97681f7646ebc507fb6e286dd1.tar.gz
gentoo-2-868fb04d7ca86b97681f7646ebc507fb6e286dd1.tar.bz2
gentoo-2-868fb04d7ca86b97681f7646ebc507fb6e286dd1.zip
new testtools
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/testtools')
-rw-r--r--dev-python/testtools/ChangeLog8
-rw-r--r--dev-python/testtools/testtools-0.9.32.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/testtools/ChangeLog b/dev-python/testtools/ChangeLog
index c3b89055d9b1..f2fe2916b23a 100644
--- a/dev-python/testtools/ChangeLog
+++ b/dev-python/testtools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/testtools
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/ChangeLog,v 1.79 2013/09/05 18:46:55 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/ChangeLog,v 1.80 2013/09/17 18:21:08 prometheanfire Exp $
+
+*testtools-0.9.32 (17 Sep 2013)
+
+ 17 Sep 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +testtools-0.9.32.ebuild:
+ new testtools
05 Sep 2013; Michał Górny <mgorny@gentoo.org> testtools-0.9.24-r1.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/dev-python/testtools/testtools-0.9.32.ebuild b/dev-python/testtools/testtools-0.9.32.ebuild
new file mode 100644
index 000000000000..a43293d5dab8
--- /dev/null
+++ b/dev-python/testtools/testtools-0.9.32.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/testtools-0.9.32.ebuild,v 1.1 2013/09/17 18:21:08 prometheanfire Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1 versionator
+
+#SERIES="$(get_version_component_range 1-2)"
+SERIES="trunk"
+
+DESCRIPTION="Extensions to the Python unittest library"
+HOMEPAGE="https://launchpad.net/testtools http://pypi.python.org/pypi/testtools"
+SRC_URI="http://launchpad.net/${PN}/${SERIES}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+#not keyworded
+# test? ( dev-python/mimeparse[${PYTHON_USEDEP}] ) "
+RDEPEND=""
+
+python_prepare() {
+ sed -i '/\_build/d' "${S}/MANIFEST.in"
+ distutils-r1_python_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+# if [[ ! -e "${BUILD_DIR}"/lib/testtools/_compat2x.py ]]; then
+# die "_compat2x.py removed upstream; fix src_compile"
+# fi
+}
+
+python_test() {
+ # XXX: tests are non-fatal currently...
+ # https://bugs.launchpad.net/testtools/+bug/1132542
+ esetup.py test
+}
+
+# dev-python/subunit imports some objects from testtools.tests.helpers, so
+# tests need to be installed.