summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-21 03:30:59 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-21 03:30:59 +0000
commit8600de0ad45bfea67062bde1a2f39f7e7e358137 (patch)
treea7e5139cbc44eb41c9e7edec95a6369e064ad0fa /dev-python/waitress
parentinitial version, contributed by Dainius Masiliūnas (GreatEmerald), polished ... (diff)
downloadgentoo-2-8600de0ad45bfea67062bde1a2f39f7e7e358137.tar.gz
gentoo-2-8600de0ad45bfea67062bde1a2f39f7e7e358137.tar.bz2
gentoo-2-8600de0ad45bfea67062bde1a2f39f7e7e358137.zip
bump; drop py2.6 add pypy suport
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/waitress')
-rw-r--r--dev-python/waitress/ChangeLog7
-rw-r--r--dev-python/waitress/waitress-0.8.9.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/waitress/ChangeLog b/dev-python/waitress/ChangeLog
index 0e649b092600..413337dac125 100644
--- a/dev-python/waitress/ChangeLog
+++ b/dev-python/waitress/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/waitress
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/waitress/ChangeLog,v 1.7 2014/04/02 21:18:50 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/waitress/ChangeLog,v 1.8 2014/05/21 03:30:59 idella4 Exp $
+
+*waitress-0.8.9 (21 May 2014)
+
+ 21 May 2014; Ian Delaney <idella4@gentoo.org> +waitress-0.8.9.ebuild:
+ bump; drop py2.6 add pypy suport
02 Apr 2014; Tim Harder <radhermit@gentoo.org> waitress-0.8.8.ebuild:
Add python3_4 support.
diff --git a/dev-python/waitress/waitress-0.8.9.ebuild b/dev-python/waitress/waitress-0.8.9.ebuild
new file mode 100644
index 000000000000..697429759292
--- /dev/null
+++ b/dev-python/waitress/waitress-0.8.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/waitress/waitress-0.8.9.ebuild,v 1.1 2014/05/21 03:30:59 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+
+# doc creation is fatally broken. well not fatally but it's bad
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python WSGI server"
+HOMEPAGE="http://docs.pylonsproject.org/projects/waitress/en/latest/ https://pypi.python.org/pypi/waitress/ https://github.com/Pylons/waitress"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ test? ( dev-python/nose )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}