summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-04 19:22:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-04 19:22:55 +0000
commit03d10bc843c21c59cc35ef24084ac2e180574c98 (patch)
tree48aaa0a591a99a260e09a090a96b79d64b91fa3b /dev-python
parentalpha/ia64/sparc stable wrt #307573 stable wrt #301548 (diff)
downloadgentoo-2-03d10bc843c21c59cc35ef24084ac2e180574c98.tar.gz
gentoo-2-03d10bc843c21c59cc35ef24084ac2e180574c98.tar.bz2
gentoo-2-03d10bc843c21c59cc35ef24084ac2e180574c98.zip
Version bump.
(Portage version: 15749-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/configobj/ChangeLog8
-rw-r--r--dev-python/configobj/configobj-4.7.2.ebuild46
-rw-r--r--dev-python/configobj/files/configobj-4.7.2-fix_tests.patch11
3 files changed, 64 insertions, 1 deletions
diff --git a/dev-python/configobj/ChangeLog b/dev-python/configobj/ChangeLog
index dee46eec1ef1..51b57c62697c 100644
--- a/dev-python/configobj/ChangeLog
+++ b/dev-python/configobj/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/configobj
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/configobj/ChangeLog,v 1.20 2010/02/27 21:20:45 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/configobj/ChangeLog,v 1.21 2010/03/04 19:22:54 arfrever Exp $
+
+*configobj-4.7.2 (04 Mar 2010)
+
+ 04 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +configobj-4.7.2.ebuild, +files/configobj-4.7.2-fix_tests.patch:
+ Version bump.
27 Feb 2010; Fabian Groffen <grobian@gentoo.org> configobj-4.7.1.ebuild:
Marked ~x64-macos, thanks Ramon van Alteren in bug #306705
diff --git a/dev-python/configobj/configobj-4.7.2.ebuild b/dev-python/configobj/configobj-4.7.2.ebuild
new file mode 100644
index 000000000000..4367ebd72a05
--- /dev/null
+++ b/dev-python/configobj/configobj-4.7.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/configobj/configobj-4.7.2.ebuild,v 1.1 2010/03/04 19:22:54 arfrever Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="Simple config file reader and writer"
+HOMEPAGE="http://www.voidspace.org.uk/python/configobj.html http://code.google.com/p/configobj/ http://pypi.python.org/pypi/configobj"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="configobj.py validate.py"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-4.7.2-fix_tests.patch"
+ sed -e "s/ \(doctest\.testmod(.*\)/ sys.exit(\1[0] != 0)/" -i validate.py
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" validate.py -v
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ rm -f docs/BSD*
+ insinto /usr/share/doc/${PF}/html
+ doins -r docs/* || die "doins failed"
+ fi
+}
diff --git a/dev-python/configobj/files/configobj-4.7.2-fix_tests.patch b/dev-python/configobj/files/configobj-4.7.2-fix_tests.patch
new file mode 100644
index 000000000000..c0b867e0ee7c
--- /dev/null
+++ b/dev-python/configobj/files/configobj-4.7.2-fix_tests.patch
@@ -0,0 +1,11 @@
+--- validate.py
++++ validate.py
+@@ -268,8 +268,6 @@
+ 16908291
+ >>> int(dottedQuadToNum('1.2.3.4'))
+ 16909060
+- >>> dottedQuadToNum('255.255.255.255')
+- 4294967295L
+ >>> dottedQuadToNum('255.255.255.256')
+ Traceback (most recent call last):
+ ValueError: Not a good dotted-quad IP: 255.255.255.256