summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-12 10:03:27 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-12 10:03:27 +0000
commitb43be419eeaf01dafda9ca8ab1461e48df03056d (patch)
treed50ecaec96d4dfbdbdf7f446f5eb26f1e533439b /dev-python
parentamd64 stable, bug #495852 (diff)
downloadgentoo-2-b43be419eeaf01dafda9ca8ab1461e48df03056d.tar.gz
gentoo-2-b43be419eeaf01dafda9ca8ab1461e48df03056d.tar.bz2
gentoo-2-b43be419eeaf01dafda9ca8ab1461e48df03056d.zip
dev-python/bottleneck: Verion BUmp
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/bottleneck/ChangeLog9
-rw-r--r--dev-python/bottleneck/bottleneck-0.7.0.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-python/bottleneck/ChangeLog b/dev-python/bottleneck/ChangeLog
index 820122f80095..9d4bfe85e88d 100644
--- a/dev-python/bottleneck/ChangeLog
+++ b/dev-python/bottleneck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/bottleneck
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bottleneck/ChangeLog,v 1.1 2013/05/04 10:10:42 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bottleneck/ChangeLog,v 1.2 2014/01/12 10:03:27 jlec Exp $
+
+*bottleneck-0.7.0 (12 Jan 2014)
+
+ 12 Jan 2014; Justin Lecher <jlec@gentoo.org> +bottleneck-0.7.0.ebuild:
+ Verion BUmp
*bottleneck-0.6.0 (04 May 2013)
diff --git a/dev-python/bottleneck/bottleneck-0.7.0.ebuild b/dev-python/bottleneck/bottleneck-0.7.0.ebuild
new file mode 100644
index 000000000000..1e7a71e406b4
--- /dev/null
+++ b/dev-python/bottleneck/bottleneck-0.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bottleneck/bottleneck-0.7.0.ebuild,v 1.1 2014/01/12 10:03:27 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+MY_PN="Bottleneck"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Fast NumPy array functions written in Cython"
+HOMEPAGE="
+ https://pypi.python.org/pypi/Bottleneck
+ http://berkeleyanalytics.com/bottleneck
+ http://github.com/kwgoodman/bottleneck"
+SRC_URI="mirror://pypi/B/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/${MY_P}
+
+python_prepare_all() {
+ emake cfiles
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ ${PYTHON} -c "import bottleneck;bottleneck.test(extra_argv=['--verbosity=3'])" || die
+}