summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-11-11 19:21:43 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-11-11 19:21:43 +0000
commitbdc22615f4881dad669f3b358a61926111065263 (patch)
tree928c2a85a1b7fff5ccdf468a9094220cde3cffca /dev-python
parentAdd static-libs USE flag. Patch by Arfrever. (diff)
downloadgentoo-2-bdc22615f4881dad669f3b358a61926111065263.tar.gz
gentoo-2-bdc22615f4881dad669f3b358a61926111065263.tar.bz2
gentoo-2-bdc22615f4881dad669f3b358a61926111065263.zip
Don't inherit unused eclass. Fix dependencies. Simplify distutils_src_test_pre_hook(). Patch by Arfrever.
(Portage version: 2.2.0_alpha73/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dulwich/ChangeLog6
-rw-r--r--dev-python/dulwich/dulwich-0.8.1.ebuild8
2 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/dulwich/ChangeLog b/dev-python/dulwich/ChangeLog
index 8d3ab2b26ac6..e922e64a4c4b 100644
--- a/dev-python/dulwich/ChangeLog
+++ b/dev-python/dulwich/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/dulwich
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.39 2011/11/10 10:37:36 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.40 2011/11/11 19:21:43 hwoarang Exp $
+
+ 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> dulwich-0.8.1.ebuild:
+ Don't inherit unused eclass. Fix dependencies. Simplify
+ distutils_src_test_pre_hook(). Patch by Arfrever.
10 Nov 2011; Fabian Groffen <grobian@gentoo.org> dulwich-0.8.1.ebuild:
Marked ~x86-linux
diff --git a/dev-python/dulwich/dulwich-0.8.1.ebuild b/dev-python/dulwich/dulwich-0.8.1.ebuild
index a9f51b0e7df9..b5c1548f72ad 100644
--- a/dev-python/dulwich/dulwich-0.8.1.ebuild
+++ b/dev-python/dulwich/dulwich-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.8.1.ebuild,v 1.2 2011/11/10 10:37:36 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.8.1.ebuild,v 1.3 2011/11/11 19:21:43 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -8,7 +8,7 @@ SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.* *-jython"
DISTUTILS_SRC_TEST="nosetests"
-inherit distutils eutils
+inherit distutils
DESCRIPTION="Dulwich is a pure-Python implementation of the Git file formats and protocols."
HOMEPAGE="http://samba.org/~jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
@@ -20,7 +20,7 @@ KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-ma
IUSE=""
DEPEND="dev-python/setuptools
- test? ( || ( dev-lang/python:2.7 dev-python/unittest2 dev-python/testtools ) )"
+ test? ( || ( dev-lang/python:2.7 dev-python/unittest2 ) )"
RDEPEND=""
src_prepare() {
@@ -31,7 +31,7 @@ src_prepare() {
distutils_src_test_pre_hook() {
local module
for module in _diff_tree _objects _pack; do
- ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/dulwich/${module}.so" "dulwich/${module}.so" || die "Symlinking dulwich/${module}.so failed with $(python_get_implementation) $(python_get_version)"
+ ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/dulwich/${module}.so" "dulwich/${module}.so" || die "Symlinking dulwich/${module}.so failed with $(python_get_implementation_and_version)"
done
}