summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-10-28 11:56:18 +0000
committerAli Polatel <hawking@gentoo.org>2008-10-28 11:56:18 +0000
commite8845ec67ce4f21b292fe04083aabc13f545706a (patch)
tree96393597749fd0c3e4a4745c3a2240d655848ed4 /dev-python
parentUse python_need_rebuild. (diff)
downloadgentoo-2-e8845ec67ce4f21b292fe04083aabc13f545706a.tar.gz
gentoo-2-e8845ec67ce4f21b292fe04083aabc13f545706a.tar.bz2
gentoo-2-e8845ec67ce4f21b292fe04083aabc13f545706a.zip
Use python_need_rebuild.
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sip/ChangeLog7
-rw-r--r--dev-python/sip/sip-4.2.1-r1.ebuild3
-rw-r--r--dev-python/sip/sip-4.2.1.ebuild7
-rw-r--r--dev-python/sip/sip-4.6.ebuild3
-rw-r--r--dev-python/sip/sip-4.7.1.ebuild3
-rw-r--r--dev-python/sip/sip-4.7.3.ebuild3
-rw-r--r--dev-python/sip/sip-4.7.5.ebuild3
-rw-r--r--dev-python/sip/sip-4.7.6.ebuild3
-rw-r--r--dev-python/sip/sip-4.7.7.ebuild3
9 files changed, 24 insertions, 11 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index 3e5656abe71c..7ec085f68f47 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/sip
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.123 2008/10/07 19:55:47 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.124 2008/10/28 11:56:18 hawking Exp $
+
+ 28 Oct 2008; Ali Polatel <hawking@gentoo.org> sip-4.2.1.ebuild,
+ sip-4.2.1-r1.ebuild, sip-4.6.ebuild, sip-4.7.1.ebuild, sip-4.7.3.ebuild,
+ sip-4.7.5.ebuild, sip-4.7.6.ebuild, sip-4.7.7.ebuild:
+ Use python_need_rebuild.
07 Oct 2008; Jeroen Roovers <jer@gentoo.org> sip-4.7.3.ebuild:
Stable for HPPA too.
diff --git a/dev-python/sip/sip-4.2.1-r1.ebuild b/dev-python/sip/sip-4.2.1-r1.ebuild
index cd976396ef8b..25e92269c501 100644
--- a/dev-python/sip/sip-4.2.1-r1.ebuild
+++ b/dev-python/sip/sip-4.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.2.1-r1.ebuild,v 1.6 2008/09/06 23:43:35 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.2.1-r1.ebuild,v 1.7 2008/10/28 11:56:18 hawking Exp $
inherit distutils
@@ -40,6 +40,7 @@ src_compile(){
}
src_install() {
+ python_need_rebuild
make DESTDIR="${D}" install || die "install failed"
dodoc ChangeLog NEWS README THANKS TODO
if use doc ; then dohtml doc/* ; fi
diff --git a/dev-python/sip/sip-4.2.1.ebuild b/dev-python/sip/sip-4.2.1.ebuild
index 78fe1c2b416c..b9d65ad00dac 100644
--- a/dev-python/sip/sip-4.2.1.ebuild
+++ b/dev-python/sip/sip-4.2.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.2.1.ebuild,v 1.14 2008/09/06 23:43:35 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.2.1.ebuild,v 1.15 2008/10/28 11:56:18 hawking Exp $
-inherit distutils
+inherit python multilib
MY_P=${P/"?.?.?_pre"/"snapshot-"}
MY_P=${MY_P/_/}
@@ -24,7 +24,7 @@ DEPEND="virtual/libc
>=dev-lang/python-2.3"
src_compile(){
- distutils_python_version
+ python_version
local myconf="-l qt-mt -b /usr/bin -d /usr/$(get_libdir)/python${PYVER}/site-packages -e /usr/include/python${PYVER}"
use debug && myconf="${myconf} -u"
@@ -34,6 +34,7 @@ src_compile(){
}
src_install() {
+ python_need_rebuild
make DESTDIR="${D}" install || die "install failed"
dodoc ChangeLog NEWS README THANKS TODO
if use doc ; then dohtml doc/* ; fi
diff --git a/dev-python/sip/sip-4.6.ebuild b/dev-python/sip/sip-4.6.ebuild
index 682cc3da362e..16b91fb17c4d 100644
--- a/dev-python/sip/sip-4.6.ebuild
+++ b/dev-python/sip/sip-4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.6.ebuild,v 1.7 2008/09/06 23:43:35 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.6.ebuild,v 1.8 2008/10/28 11:56:18 hawking Exp $
NEED_PYTHON=2.3
@@ -43,6 +43,7 @@ src_compile(){
}
src_install() {
+ python_need_rebuild
emake DESTDIR="${D}" install || die "emake install failed"
dodoc ChangeLog NEWS README THANKS TODO doc/sipref.txt
dohtml doc/*
diff --git a/dev-python/sip/sip-4.7.1.ebuild b/dev-python/sip/sip-4.7.1.ebuild
index 12389879e111..9f31ab2b4dda 100644
--- a/dev-python/sip/sip-4.7.1.ebuild
+++ b/dev-python/sip/sip-4.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.1.ebuild,v 1.10 2008/09/06 23:43:35 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.1.ebuild,v 1.11 2008/10/28 11:56:18 hawking Exp $
NEED_PYTHON=2.3
@@ -43,6 +43,7 @@ src_compile(){
}
src_install() {
+ python_need_rebuild
emake DESTDIR="${D}" install || die "emake install failed"
dodoc ChangeLog NEWS README THANKS TODO doc/sipref.txt
dohtml doc/*
diff --git a/dev-python/sip/sip-4.7.3.ebuild b/dev-python/sip/sip-4.7.3.ebuild
index bf313b4bc91a..ad7862f9d957 100644
--- a/dev-python/sip/sip-4.7.3.ebuild
+++ b/dev-python/sip/sip-4.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.3.ebuild,v 1.12 2008/10/07 19:55:47 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.3.ebuild,v 1.13 2008/10/28 11:56:18 hawking Exp $
NEED_PYTHON=2.3
@@ -43,6 +43,7 @@ src_compile(){
}
src_install() {
+ python_need_rebuild
emake DESTDIR="${D}" install || die "emake install failed"
dodoc ChangeLog NEWS README THANKS TODO doc/sipref.txt
dohtml doc/*
diff --git a/dev-python/sip/sip-4.7.5.ebuild b/dev-python/sip/sip-4.7.5.ebuild
index 838941d3c428..cc80449ce542 100644
--- a/dev-python/sip/sip-4.7.5.ebuild
+++ b/dev-python/sip/sip-4.7.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.5.ebuild,v 1.3 2008/09/06 23:43:35 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.5.ebuild,v 1.4 2008/10/28 11:56:18 hawking Exp $
NEED_PYTHON=2.3
@@ -43,6 +43,7 @@ src_compile(){
}
src_install() {
+ python_need_rebuild
emake DESTDIR="${D}" install || die "emake install failed"
dodoc ChangeLog NEWS README THANKS TODO doc/sipref.txt
dohtml doc/*
diff --git a/dev-python/sip/sip-4.7.6.ebuild b/dev-python/sip/sip-4.7.6.ebuild
index 23668e4bb52d..bb795bae2d84 100644
--- a/dev-python/sip/sip-4.7.6.ebuild
+++ b/dev-python/sip/sip-4.7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.6.ebuild,v 1.4 2008/09/06 23:43:35 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.6.ebuild,v 1.5 2008/10/28 11:56:18 hawking Exp $
NEED_PYTHON=2.3
@@ -43,6 +43,7 @@ src_compile(){
}
src_install() {
+ python_need_rebuild
emake DESTDIR="${D}" install || die "emake install failed"
dodoc ChangeLog NEWS README TODO doc/sipref.txt
dohtml doc/*
diff --git a/dev-python/sip/sip-4.7.7.ebuild b/dev-python/sip/sip-4.7.7.ebuild
index bf32843b6462..9fdf46a83215 100644
--- a/dev-python/sip/sip-4.7.7.ebuild
+++ b/dev-python/sip/sip-4.7.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.7.ebuild,v 1.2 2008/09/06 23:43:35 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.7.ebuild,v 1.3 2008/10/28 11:56:18 hawking Exp $
NEED_PYTHON=2.3
@@ -43,6 +43,7 @@ src_compile(){
}
src_install() {
+ python_need_rebuild
emake DESTDIR="${D}" install || die "emake install failed"
dodoc ChangeLog NEWS README TODO doc/sipref.txt
dohtml doc/*