summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-01-03 08:06:04 +0000
committerHans de Graaff <graaff@gentoo.org>2013-01-03 08:06:04 +0000
commit967fe8f99a1dd48cb820d7713980afadbb5a9dd8 (patch)
tree2879811f6ce74f2d6ccdbbbe693c698f9e36b9a8 /dev-ruby/actionmailer
parentVersion bump for security bug 449826. (diff)
downloadgentoo-2-967fe8f99a1dd48cb820d7713980afadbb5a9dd8.tar.gz
gentoo-2-967fe8f99a1dd48cb820d7713980afadbb5a9dd8.tar.bz2
gentoo-2-967fe8f99a1dd48cb820d7713980afadbb5a9dd8.zip
Version bump for security bug 449826.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.0.18.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 3393724addfe..8317cc1d0857 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.202 2013/01/03 07:27:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.203 2013/01/03 08:06:04 graaff Exp $
+
+*actionmailer-3.0.18 (03 Jan 2013)
+
+ 03 Jan 2013; Hans de Graaff <graaff@gentoo.org> +actionmailer-3.0.18.ebuild:
+ Version bump for security bug 449826.
*actionmailer-3.1.9 (03 Jan 2013)
diff --git a/dev-ruby/actionmailer/actionmailer-3.0.18.ebuild b/dev-ruby/actionmailer/actionmailer-3.0.18.ebuild
new file mode 100644
index 000000000000..9ff2342d97f7
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.0.18.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.0.18.ebuild,v 1.1 2013/01/03 08:06:04 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionmailer"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.2.19"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.10.5
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ sed -i -e '/dependency.*mail/s:~>:>=:' "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ # Rename private method to avoid conflict with the simple_format
+ # TextHelper. Already fixed in Rails 3.1.
+ sed -i -e 's/simple_format/format_paragraph/' lib/action_mailer/mail_helper.rb || die
+}