summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-27 08:24:39 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-27 08:24:39 +0000
commitebc446211a45905a0a4381a5738f081fb3c68927 (patch)
treed448b4162c6da43058e8dd5173b4c13fccf147b0 /dev-ruby/activeresource
parentVersion bump. Drop keywords due to new dependencies, bug 396177. (diff)
downloadgentoo-2-ebc446211a45905a0a4381a5738f081fb3c68927.tar.gz
gentoo-2-ebc446211a45905a0a4381a5738f081fb3c68927.tar.bz2
gentoo-2-ebc446211a45905a0a4381a5738f081fb3c68927.zip
Version bump. Drop keywords due to new dependencies, bug 396177.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activeresource')
-rw-r--r--dev-ruby/activeresource/ChangeLog7
-rw-r--r--dev-ruby/activeresource/activeresource-3.1.3.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index a915403ef393..54d08f5954e0 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.99 2011/11/19 11:00:59 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.100 2011/12/27 08:24:39 graaff Exp $
+
+*activeresource-3.1.3 (27 Dec 2011)
+
+ 27 Dec 2011; Hans de Graaff <graaff@gentoo.org> +activeresource-3.1.3.ebuild:
+ Version bump. Drop keywords due to new dependencies, bug 396177.
*activeresource-3.0.11 (19 Nov 2011)
diff --git a/dev-ruby/activeresource/activeresource-3.1.3.ebuild b/dev-ruby/activeresource/activeresource-3.1.3.ebuild
new file mode 100644
index 000000000000..714f4c7b212b
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-3.1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.1.3.ebuild,v 1.1 2011/12/27 08:24:39 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activeresource"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+}