summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerris McCormick <fmccor@gentoo.org>2005-09-23 14:24:10 +0000
committerFerris McCormick <fmccor@gentoo.org>2005-09-23 14:24:10 +0000
commit73bf04542a7df1f03aa2dec475b87a7df5ca5cae (patch)
tree972bfb22cf8c1af9168f2374f42ab3cb9ddb13f0 /dev-ruby/fxruby/fxruby-1.2.2.ebuild
parentAdded Slovak longdescription. (diff)
downloadgentoo-2-73bf04542a7df1f03aa2dec475b87a7df5ca5cae.tar.gz
gentoo-2-73bf04542a7df1f03aa2dec475b87a7df5ca5cae.tar.bz2
gentoo-2-73bf04542a7df1f03aa2dec475b87a7df5ca5cae.zip
Do not force '-O0' when building fxruby. Closes Bug #87016 at request
of the developer, caleb@gentoo.org. (Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-ruby/fxruby/fxruby-1.2.2.ebuild')
-rw-r--r--dev-ruby/fxruby/fxruby-1.2.2.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-ruby/fxruby/fxruby-1.2.2.ebuild b/dev-ruby/fxruby/fxruby-1.2.2.ebuild
index c56fa35cde8c..98b85cff418f 100644
--- a/dev-ruby/fxruby/fxruby-1.2.2.ebuild
+++ b/dev-ruby/fxruby/fxruby-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.2.2.ebuild,v 1.8 2005/09/02 12:48:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.2.2.ebuild,v 1.9 2005/09/23 14:24:10 fmccor Exp $
inherit ruby
@@ -20,6 +20,14 @@ DEPEND=">=x11-libs/fox-1.2
USE_RUBY="ruby16 ruby18 ruby19"
S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+ einfo "Avoid all -O0 builds"
+ cd ${S}
+ sed -i -e 's:-O0 -Iinclude:-Iinclude:g' \
+ ext/fox12/extconf.rb || die "Can't fix forced -O0"
+}
+
src_compile() {
ruby install.rb config --prefix=/usr || die
ruby install.rb setup || die