summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-14 07:42:15 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-14 07:42:15 +0000
commitdcb1435b7540c6b77bcacf1877e7c84452dab913 (patch)
treec75cd69f3b6524b71aa32a6fe1952f1e28a8a161 /dev-ruby/narray
parent2.1 also stable on x86 for older kernels... bug 338420 (diff)
downloadgentoo-2-dcb1435b7540c6b77bcacf1877e7c84452dab913.tar.gz
gentoo-2-dcb1435b7540c6b77bcacf1877e7c84452dab913.tar.bz2
gentoo-2-dcb1435b7540c6b77bcacf1877e7c84452dab913.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/narray')
-rw-r--r--dev-ruby/narray/ChangeLog7
-rw-r--r--dev-ruby/narray/narray-0.6.0.1.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-ruby/narray/ChangeLog b/dev-ruby/narray/ChangeLog
index 59381195b421..2da852d35bdf 100644
--- a/dev-ruby/narray/ChangeLog
+++ b/dev-ruby/narray/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/narray
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/ChangeLog,v 1.42 2011/06/16 09:13:40 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/ChangeLog,v 1.43 2011/09/14 07:42:15 graaff Exp $
+
+*narray-0.6.0.1 (14 Sep 2011)
+
+ 14 Sep 2011; Hans de Graaff <graaff@gentoo.org> +narray-0.6.0.1.ebuild:
+ Version bump.
*narray-0.5.9_p9 (16 Jun 2011)
diff --git a/dev-ruby/narray/narray-0.6.0.1.ebuild b/dev-ruby/narray/narray-0.6.0.1.ebuild
new file mode 100644
index 000000000000..3a323c0626a9
--- /dev/null
+++ b/dev-ruby/narray/narray-0.6.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/narray-0.6.0.1.ebuild,v 1.1 2011/09/14 07:42:15 graaff Exp $
+
+EAPI=4
+
+# jruby → native extension
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.en README.ja SPEC.en SPEC.ja"
+
+RUBY_FAKEGEM_VERSION="${PV/_p/.}"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Numerical N-dimensional Array class"
+HOMEPAGE="http://www.ir.isas.ac.jp/~masa/ruby/index-e.html"
+SRC_URI="mirror://rubyforge/${PN}/${P/_/}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE=""
+
+all_ruby_prepare() {
+ # the tests aren't really written to be a testsuite, so the
+ # failure cases will literally fail; ignore all of those ad
+ # instead expect that the rest won't fail.
+ sed -i -e '/[fF]ollowing will fail/,$ s:^:#:' \
+ test/*.rb || die "sed failed"
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed"
+ cp -l ${PN}$(get_modname) lib || die "copy of ${PN}$(get_modname) failed"
+}
+
+each_ruby_test() {
+ for unit in test/*; do
+ # Skip over the FFTW test because it needs a package we don't
+ # have in tree.
+ [[ ${unit} == test/testfftw.rb ]] && continue
+
+ ${RUBY} -Ilib ${unit} || die "test ${unit} failed"
+ done
+}