summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-06-03 19:33:59 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-06-03 19:33:59 +0000
commit04dc603aa4f484d17da9e3f1769e606ad9b22dbe (patch)
tree85bce03ee60f8d4312d491373a577bc837418df7 /dev-tcltk/tcldom
parent- stable on arm (diff)
downloadgentoo-2-04dc603aa4f484d17da9e3f1769e606ad9b22dbe.tar.gz
gentoo-2-04dc603aa4f484d17da9e3f1769e606ad9b22dbe.tar.bz2
gentoo-2-04dc603aa4f484d17da9e3f1769e606ad9b22dbe.zip
Fixed bash-3.1 problem, Bug 131148.
(Portage version: 2.1_rc4)
Diffstat (limited to 'dev-tcltk/tcldom')
-rw-r--r--dev-tcltk/tcldom/ChangeLog12
-rw-r--r--dev-tcltk/tcldom/files/digest-tcldom-3.13
-rw-r--r--dev-tcltk/tcldom/tcldom-3.1.ebuild67
3 files changed, 79 insertions, 3 deletions
diff --git a/dev-tcltk/tcldom/ChangeLog b/dev-tcltk/tcldom/ChangeLog
index 3e1390185660..f023ec92986b 100644
--- a/dev-tcltk/tcldom/ChangeLog
+++ b/dev-tcltk/tcldom/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/tcldom
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcldom/ChangeLog,v 1.6 2005/06/26 03:34:28 matsuu Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcldom/ChangeLog,v 1.7 2006/06/03 19:33:59 matsuu Exp $
+
+*tcldom-3.1 (03 Jun 2006)
+
+ 03 Jun 2006; MATSUU Takuto <matsuu@gentoo.org> +tcldom-3.1.ebuild:
+ Version bumped.
+ Fixed bash-3.1 issue, Bug 131148.
*tcldom-3.0 (26 Jun 2005)
@@ -8,7 +14,7 @@
Version bumped.
Added some USE flags.
- 12 May 2005; Olivier Crête <tester@gentoo.org> tcldom-2.6.ebuild:
+ 12 May 2005; Olivier Cr棚te <tester@gentoo.org> tcldom-2.6.ebuild:
Marking ~amd64
06 Nov 2004; <pyrania@gentoo.org> tcldom-2.6.ebuild:
diff --git a/dev-tcltk/tcldom/files/digest-tcldom-3.1 b/dev-tcltk/tcldom/files/digest-tcldom-3.1
new file mode 100644
index 000000000000..bafe246419a7
--- /dev/null
+++ b/dev-tcltk/tcldom/files/digest-tcldom-3.1
@@ -0,0 +1,3 @@
+MD5 b5af0e29e5cf2109d1f1a9b1a6ec2d81 tcldom-3.1.tar.gz 395572
+RMD160 105decfa022a781b2483e2a4909cc857027ca32f tcldom-3.1.tar.gz 395572
+SHA256 1eabfe884a072f18bd18b1ec9c495145057442e072fe5288d9742058d93278ed tcldom-3.1.tar.gz 395572
diff --git a/dev-tcltk/tcldom/tcldom-3.1.ebuild b/dev-tcltk/tcldom/tcldom-3.1.ebuild
new file mode 100644
index 000000000000..e0a46eb0c45c
--- /dev/null
+++ b/dev-tcltk/tcldom/tcldom-3.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcldom/tcldom-3.1.ebuild,v 1.1 2006/06/03 19:33:59 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="Document Object Model For Tcl"
+HOMEPAGE="http://tclxml.sourceforge.net/tcldom.html"
+SRC_URI="mirror://sourceforge/tclxml/${P}.tar.gz"
+
+IUSE="expat xml2 threads"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=">=dev-lang/tcl-8.3.3
+ >=dev-tcltk/tcllib-1.2
+ ~dev-tcltk/tclxml-3.1
+ expat? ( dev-libs/expat )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}/library"
+ sed -e "s/@VERSION@/${PV}/" \
+ -e "s/@Tcldom_LIB_FILE@@/UNSPECIFIED/" \
+ < pkgIndex.tcl.in > pkgIndex.tcl
+
+ # bug 131148
+ sed -i -e "s/relid'/relid/" "${S}"/*/{configure,tcl.m4} || die
+}
+
+src_compile() {
+ local myconf=""
+
+ use threads && myconf="${myconf} --enable-threads"
+
+ if use xml2 ; then
+ cd "${S}/src-libxml2"
+ econf ${myconf} || die
+ emake || die
+ fi
+ if use expat ; then
+ cd "${S}/src"
+ econf ${myconf} || die
+ emake || die
+ fi
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/${PN}${PV}
+ doins library/*.tcl || die
+
+ if use xml2 ; then
+ cd "${S}/src-libxml2"
+ make DESTDIR="${D}" install || die
+ fi
+ if use expat ; then
+ cd "${S}/src"
+ make DESTDIR="${D}" install || die
+ fi
+
+ cd "${S}"
+ dodoc ChangeLog LICENSE README RELNOTES
+ docinto examples; dodoc examples/*
+ dohtml docs/*.html
+}