summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-25 17:17:46 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-25 17:17:46 +0000
commitbeba56cfbe7ed66d8f70a9b0701d85802cae9d2f (patch)
treef539904f93647faf516c83f36db4d3695617be65 /dev-tcltk/thread
parentStable on amd64 wrt bug #364355 (diff)
downloadgentoo-2-beba56cfbe7ed66d8f70a9b0701d85802cae9d2f.tar.gz
gentoo-2-beba56cfbe7ed66d8f70a9b0701d85802cae9d2f.tar.bz2
gentoo-2-beba56cfbe7ed66d8f70a9b0701d85802cae9d2f.zip
Fixed missing debug in IUSE, #364811; Fix build with USE=-gdbm, #247586
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/thread')
-rw-r--r--dev-tcltk/thread/ChangeLog8
-rw-r--r--dev-tcltk/thread/thread-2.6.2.ebuild15
-rw-r--r--dev-tcltk/thread/thread-2.6.6.ebuild13
3 files changed, 21 insertions, 15 deletions
diff --git a/dev-tcltk/thread/ChangeLog b/dev-tcltk/thread/ChangeLog
index 76e590a0537b..3596f27e016a 100644
--- a/dev-tcltk/thread/ChangeLog
+++ b/dev-tcltk/thread/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tcltk/thread
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/ChangeLog,v 1.17 2010/12/07 13:40:29 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/ChangeLog,v 1.18 2011/04/25 17:17:46 jlec Exp $
+
+ 25 Apr 2011; Justin Lecher <jlec@gentoo.org> thread-2.6.2.ebuild,
+ thread-2.6.6.ebuild:
+ Fixed missing debug in IUSE, #364811; Fix build with USE=-gdbm, #247586
*thread-2.6.6 (07 Dec 2010)
diff --git a/dev-tcltk/thread/thread-2.6.2.ebuild b/dev-tcltk/thread/thread-2.6.2.ebuild
index 5765584c26ad..23b43ae5e8e7 100644
--- a/dev-tcltk/thread/thread-2.6.2.ebuild
+++ b/dev-tcltk/thread/thread-2.6.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.2.ebuild,v 1.16 2010/12/07 13:40:30 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.2.ebuild,v 1.17 2011/04/25 17:17:46 jlec Exp $
EAPI=2
@@ -31,18 +31,17 @@ src_prepare() {
sed -i -e "s/relid'/relid/" tclconfig/tcl.m4
- eaclocal
- eautoconf
+ eautoreconf
}
src_configure() {
- local use_gdbm=""
- if use gdbm; then use_gdbm="--with-gdbm"; fi
+ local myconf=""
+ use gdbm && myconf+=" --with-gdbm"
+ use debug && myconf+=" --enable-symbols"
econf \
- --with-threads \
--with-tclinclude=/usr/include \
--with-tcl="/usr/$(get_libdir)" \
- ${use_gdbm}
+ ${myconf}
}
src_install() {
diff --git a/dev-tcltk/thread/thread-2.6.6.ebuild b/dev-tcltk/thread/thread-2.6.6.ebuild
index 38aac39f5daa..b6c8cee5a093 100644
--- a/dev-tcltk/thread/thread-2.6.6.ebuild
+++ b/dev-tcltk/thread/thread-2.6.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.6.ebuild,v 1.1 2010/12/07 13:40:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.6.ebuild,v 1.2 2011/04/25 17:17:46 jlec Exp $
EAPI=2
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/tcl/${PN}${PV}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="gdbm"
+IUSE="debug gdbm"
DEPEND="
dev-lang/tcl[threads]
@@ -35,11 +35,14 @@ src_prepare() {
}
src_configure() {
+ local myconf=""
+ use gdbm && myconf+=" --with-gdbm"
+ use debug && myconf+=" --enable-symbols"
econf \
--with-tclinclude=/usr/include \
--with-tcl="/usr/$(get_libdir)" \
- $(use_with gdbm) \
- $(use_enable debug symbols)
+ ${myconf}
+
}
src_install() {