summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-04-13 09:13:40 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-04-13 09:13:40 +0000
commit9615a459a0f53683e4cd259773926bb09876b1fb (patch)
treea701ec8c2bda685afa1d7ed454a6ef93e75b4691 /dev-tex/chktex
parentStable for alpha, wrt bug #530600 (diff)
downloadgentoo-2-9615a459a0f53683e4cd259773926bb09876b1fb.tar.gz
gentoo-2-9615a459a0f53683e4cd259773926bb09876b1fb.tar.bz2
gentoo-2-9615a459a0f53683e4cd259773926bb09876b1fb.zip
version bump
Signed-off-by: Alexis Ballier <aballier@gentoo.org> (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-tex/chktex')
-rw-r--r--dev-tex/chktex/ChangeLog9
-rw-r--r--dev-tex/chktex/chktex-1.7.3.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-tex/chktex/ChangeLog b/dev-tex/chktex/ChangeLog
index 8d3c6e512faf..ab9ca1c4efc7 100644
--- a/dev-tex/chktex/ChangeLog
+++ b/dev-tex/chktex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/chktex
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/chktex/ChangeLog,v 1.56 2013/05/17 11:01:24 aballier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/chktex/ChangeLog,v 1.57 2015/04/13 09:13:40 aballier Exp $
+
+*chktex-1.7.3 (13 Apr 2015)
+
+ 13 Apr 2015; Alexis Ballier <aballier@gentoo.org> +chktex-1.7.3.ebuild:
+ version bump
*chktex-1.7.2 (17 May 2013)
diff --git a/dev-tex/chktex/chktex-1.7.3.ebuild b/dev-tex/chktex/chktex-1.7.3.ebuild
new file mode 100644
index 000000000000..aa419b1c4fc0
--- /dev/null
+++ b/dev-tex/chktex/chktex-1.7.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/chktex/chktex-1.7.3.ebuild,v 1.1 2015/04/13 09:13:40 aballier Exp $
+
+EAPI=4
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Checks latex source for common mistakes"
+HOMEPAGE="http://www.nongnu.org/chktex/"
+SRC_URI="http://download.savannah.gnu.org/releases/chktex/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug doc +pcre test"
+# Tests fail without pcre. Enable pcre by default and make tests depend on it.
+REQUIRED_USE="test? ( pcre )"
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}
+ sys-apps/groff
+ doc? ( dev-tex/latex2html )"
+
+PATCHES=( "${FILESDIR}/${PN}-1.7.1-asneeded.patch" )
+DOCS=( NEWS )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug debug-info)
+ $(use_enable pcre)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile html
+}
+
+src_install() {
+ if use doc ; then
+ HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/HTML/ChkTeX/")
+ DOCS+=("${AUTOTOOLS_BUILD_DIR}/HTML/ChkTeX.tex")
+ fi
+ autotools-utils_src_install
+ doman *.1
+}