summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-06-27 14:46:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-06-27 14:46:50 +0000
commit9f958e048743f69084af9ce7700610cc7887e977 (patch)
treece2a919963d25fcf8e426de44df9e5aec1c3a13b /dev-tex/curve
parentdepend on tl-latexextra for lastpage.sty, by Łukasz Stelmach, bug #360129 (diff)
downloadgentoo-2-9f958e048743f69084af9ce7700610cc7887e977.tar.gz
gentoo-2-9f958e048743f69084af9ce7700610cc7887e977.tar.bz2
gentoo-2-9f958e048743f69084af9ce7700610cc7887e977.zip
version bump, by Johannes Rauh, bug #359815
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'dev-tex/curve')
-rw-r--r--dev-tex/curve/ChangeLog7
-rw-r--r--dev-tex/curve/curve-1.16.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-tex/curve/ChangeLog b/dev-tex/curve/ChangeLog
index 73461d44ece7..05e30ef56460 100644
--- a/dev-tex/curve/ChangeLog
+++ b/dev-tex/curve/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/curve
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/curve/ChangeLog,v 1.14 2011/06/27 14:14:44 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/curve/ChangeLog,v 1.15 2011/06/27 14:46:50 aballier Exp $
+
+*curve-1.16 (27 Jun 2011)
+
+ 27 Jun 2011; Alexis Ballier <aballier@gentoo.org> +curve-1.16.ebuild:
+ version bump, by Johannes Rauh, bug #359815
27 Jun 2011; Alexis Ballier <aballier@gentoo.org> -curve-1.11.ebuild:
remove old
diff --git a/dev-tex/curve/curve-1.16.ebuild b/dev-tex/curve/curve-1.16.ebuild
new file mode 100644
index 000000000000..aad503037c72
--- /dev/null
+++ b/dev-tex/curve/curve-1.16.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/curve/curve-1.16.ebuild,v 1.1 2011/06/27 14:46:50 aballier Exp $
+
+EAPI=2
+
+inherit latex-package
+
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="LaTeX style for a CV (curriculum vitae) with flavour option"
+SRC_URI="ftp://tug.ctan.org/pub/tex-archive/macros/latex/contrib/${PN}.zip -> ${P}.zip"
+HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/curve/"
+LICENSE="LPPL-1.2"
+RDEPEND=">=dev-texlive/texlive-latexextra-2010"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+IUSE="doc examples"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+TEXMF=/usr/share/texmf-site
+
+src_install() {
+
+ latex-package_src_doinstall styles
+
+ dodoc README NEWS THANKS
+
+ if use doc ; then
+ latex-package_src_doinstall pdf
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/example
+ doins examples/*
+ fi
+}