summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-08-11 09:29:13 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-08-11 09:29:13 +0000
commit10482eb57f8c12700197825679261382a21c1e50 (patch)
tree9e4615271ad5034bd330c3508cb7c65cae80728d /dev-util/cppunit
parentadd ruby19 support (diff)
downloadgentoo-2-10482eb57f8c12700197825679261382a21c1e50.tar.gz
gentoo-2-10482eb57f8c12700197825679261382a21c1e50.tar.bz2
gentoo-2-10482eb57f8c12700197825679261382a21c1e50.zip
Add live ebuild for the fun of it.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cppunit')
-rw-r--r--dev-util/cppunit/ChangeLog7
-rw-r--r--dev-util/cppunit/cppunit-9999.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-util/cppunit/ChangeLog b/dev-util/cppunit/ChangeLog
index 35d7f8b8b857..48d0e07adf03 100644
--- a/dev-util/cppunit/ChangeLog
+++ b/dev-util/cppunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cppunit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/ChangeLog,v 1.66 2012/08/06 14:23:45 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/ChangeLog,v 1.67 2012/08/11 09:29:13 scarabeus Exp $
+
+*cppunit-9999 (11 Aug 2012)
+
+ 11 Aug 2012; Tomáš Chvátal <scarabeus@gentoo.org> +cppunit-9999.ebuild:
+ Add live ebuild for the fun of it.
06 Aug 2012; Tomáš Chvátal <scarabeus@gentoo.org> cppunit-1.13.0.ebuild:
Set new homepage.
diff --git a/dev-util/cppunit/cppunit-9999.ebuild b/dev-util/cppunit/cppunit-9999.ebuild
new file mode 100644
index 000000000000..ec9c16ab6dd2
--- /dev/null
+++ b/dev-util/cppunit/cppunit-9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-9999.ebuild,v 1.1 2012/08/11 09:29:13 scarabeus Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/libreoffice/cppunit"
+[[ ${PV} = 9999 ]] && inherit git-2 autotools
+inherit eutils flag-o-matic
+
+DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/cppunit"
+[[ ${PV} = 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+[[ ${PV} = 9999 ]] || KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen[dot]
+ media-gfx/graphviz
+ )"
+
+DOCS=( AUTHORS BUGS NEWS README THANKS TODO doc/FAQ )
+[[ ${PV} = 9999 ]] || DOCS+=" ChangeLog"
+
+src_prepare() {
+ [[ ${PV} = 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # Anything else than -O0 breaks on alpha
+ use alpha && replace-flags "-O?" -O0
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable doc doxygen) \
+ $(use_enable doc dot) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ if use examples ; then
+ find examples -iname "*.o" -delete
+ insinto /usr/share/${PN}
+ doins -r examples
+ fi
+}