summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaik Schreiber <blizzy@gentoo.org>2002-07-15 01:54:32 +0000
committerMaik Schreiber <blizzy@gentoo.org>2002-07-15 01:54:32 +0000
commite7a2615b18346306980ceb16acdbad0227241cb8 (patch)
treecdfd528e54afc9c1504730fc886145f5a91f13c3 /dev-util/sashxb
parentversion bump (diff)
downloadgentoo-2-e7a2615b18346306980ceb16acdbad0227241cb8.tar.gz
gentoo-2-e7a2615b18346306980ceb16acdbad0227241cb8.tar.bz2
gentoo-2-e7a2615b18346306980ceb16acdbad0227241cb8.zip
new version, closes bug #4865
Diffstat (limited to 'dev-util/sashxb')
-rw-r--r--dev-util/sashxb/ChangeLog8
-rw-r--r--dev-util/sashxb/files/digest-sashxb-1.0.21
-rw-r--r--dev-util/sashxb/sashxb-1.0.2.ebuild58
3 files changed, 66 insertions, 1 deletions
diff --git a/dev-util/sashxb/ChangeLog b/dev-util/sashxb/ChangeLog
index fe92b6c454ed..41cdf22b4abd 100644
--- a/dev-util/sashxb/ChangeLog
+++ b/dev-util/sashxb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/sashxb
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/sashxb/ChangeLog,v 1.1 2002/07/09 22:12:49 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sashxb/ChangeLog,v 1.2 2002/07/15 01:54:32 blizzy Exp $
+
+*sashxb-1.0.2 (15 Jul 2002)
+
+ 15 Jul 2002; Maik Schreiber <blizzy@gentoo.org> :
+
+ New version, closes bug #4865.
*sashxb-1.0.1 (10 Jul 2002)
diff --git a/dev-util/sashxb/files/digest-sashxb-1.0.2 b/dev-util/sashxb/files/digest-sashxb-1.0.2
new file mode 100644
index 000000000000..9a2a852c5f8e
--- /dev/null
+++ b/dev-util/sashxb/files/digest-sashxb-1.0.2
@@ -0,0 +1 @@
+MD5 724c2d186f53951ef77de75a28a1c1ec sashxb-1.0.2.tar.gz 449009
diff --git a/dev-util/sashxb/sashxb-1.0.2.ebuild b/dev-util/sashxb/sashxb-1.0.2.ebuild
new file mode 100644
index 000000000000..e2b29f4611f6
--- /dev/null
+++ b/dev-util/sashxb/sashxb-1.0.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sashxb/sashxb-1.0.2.ebuild,v 1.1 2002/07/15 01:54:32 blizzy Exp $
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="Application environment for HTML and JS developers."
+HOMEPAGE="http://oss.software.ibm.com/developerworks/opensource/sashxb/"
+SRC_URI="http://oss.software.ibm.com/developerworks/opensource/sashxb/download/runtime/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86"
+
+RDEPEND=">=virtual/glibc-2.2.3
+ >=net-www/mozilla-1.0
+ >=dev-libs/gdome2-0.7
+ dev-libs/libxml2
+ sys-devel/gettext
+ gnome-base/libglade
+ gnome-base/ORBit
+ sys-apps/e2fsprogs
+ media-libs/gdk-pixbuf
+ gnome-base/gnome-core
+ gnome-base/gnome-libs"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ patch -p1 -i ${FILESDIR}/${P}-mozilla.patch
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-mozilla-lib=/usr/lib/mozilla \
+ --with-mozilla-include=/usr/include/mozilla \
+ --with-mozilla-idl=/usr/lib/mozilla/include/idl \
+ || die "configure problem"
+
+ emake || die "compile problem"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "install problem"
+
+ dodoc ABOUT-NLS COPYING README TODO
+}
+
+pkg_postinst() {
+ einfo "The SashXB runtime has been installed. You may want to take a"
+ einfo "look at the Weblications gallery now, and install some of them"
+ einfo "from your regular user account (that means, *not* as root"
+ einfo "unless you know what you're doing):"
+ einfo ""
+ einfo "\thttp://oss.software.ibm.com/developerworks/opensource/sashxb/download/gallery.html"
+ einfo ""
+ einfo "For example, to install the Registry Test, type:"
+ einfo
+ einfo "\tsash-install regtest"
+}