summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-10-03 04:17:19 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-10-03 04:17:19 +0000
commit29fbaa493d7b0edad7351b38b02cd7d831e85fd6 (patch)
treefae6af89c24fd6dab4043d36ff34f2a9034d242f /dev-util/wxglade
parentversion bump for GNOME 2.20 (diff)
downloadgentoo-2-29fbaa493d7b0edad7351b38b02cd7d831e85fd6.tar.gz
gentoo-2-29fbaa493d7b0edad7351b38b02cd7d831e85fd6.tar.bz2
gentoo-2-29fbaa493d7b0edad7351b38b02cd7d831e85fd6.zip
Lock wxpython dependency. Fix quoting. Remove old.
(Portage version: 2.1.3.11)
Diffstat (limited to 'dev-util/wxglade')
-rw-r--r--dev-util/wxglade/ChangeLog6
-rw-r--r--dev-util/wxglade/files/digest-wxglade-0.53
-rw-r--r--dev-util/wxglade/wxglade-0.4.1.ebuild8
-rw-r--r--dev-util/wxglade/wxglade-0.5.ebuild43
4 files changed, 9 insertions, 51 deletions
diff --git a/dev-util/wxglade/ChangeLog b/dev-util/wxglade/ChangeLog
index 605a26b004c6..fa55c482a62d 100644
--- a/dev-util/wxglade/ChangeLog
+++ b/dev-util/wxglade/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/wxglade
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/ChangeLog,v 1.36 2007/09/24 04:14:07 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/ChangeLog,v 1.37 2007/10/03 04:17:18 dirtyepic Exp $
+
+ 03 Oct 2007; Ryan Hill <dirtyepic@gentoo.org> wxglade-0.4.1.ebuild,
+ -wxglade-0.5.ebuild:
+ Lock wxpython dependency. Fix quoting. Remove old.
24 Sep 2007; Ryan Hill <dirtyepic@gentoo.org> wxglade-0.6.ebuild:
Use get_libdir everywhere.
diff --git a/dev-util/wxglade/files/digest-wxglade-0.5 b/dev-util/wxglade/files/digest-wxglade-0.5
deleted file mode 100644
index 1321915ee043..000000000000
--- a/dev-util/wxglade/files/digest-wxglade-0.5
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 705855ef251053bd6b032bc5667cea19 wxGlade-0.5.tar.gz 536399
-RMD160 ba2243ddc1e9568aa9b5a128b7fef76721e31a3d wxGlade-0.5.tar.gz 536399
-SHA256 b5e5eec0296354e131ee4686cb010b2e67231359d3707d75ef9edc8f88c4f753 wxGlade-0.5.tar.gz 536399
diff --git a/dev-util/wxglade/wxglade-0.4.1.ebuild b/dev-util/wxglade/wxglade-0.4.1.ebuild
index e4682a6d1dfc..0b7fa977e7ec 100644
--- a/dev-util/wxglade/wxglade-0.4.1.ebuild
+++ b/dev-util/wxglade/wxglade-0.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/wxglade-0.4.1.ebuild,v 1.5 2007/05/19 18:35:17 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/wxglade-0.4.1.ebuild,v 1.6 2007/10/03 04:17:18 dirtyepic Exp $
inherit python
@@ -14,16 +14,16 @@ KEYWORDS="amd64 ppc sparc x86"
IUSE=""
S="${WORKDIR}/${MY_P}"
DEPEND=">=dev-lang/python-2.2
- >=dev-python/wxpython-2.6"
+ =dev-python/wxpython-2.6*"
src_install() {
python_version
dodir /usr/lib/python${PYVER}/site-packages/${PN}
dodoc *txt
- cp credits.txt ${D}/usr/lib/python${PYVER}/site-packages/${PN}/
+ cp credits.txt "${D}"/usr/lib/python${PYVER}/site-packages/${PN}/
dohtml -r docs/*
rm -rf docs *txt
- cp -R * ${D}/usr/lib/python${PYVER}/site-packages/${PN}/
+ cp -R * "${D}"/usr/lib/python${PYVER}/site-packages/${PN}/
dosym /usr/share/doc/${PF}/html /usr/lib/python${PYVER}/site-packages/${PN}/docs
echo "#!/bin/bash" > wxglade
echo "exec python /usr/lib/python${PYVER}/site-packages/${PN}/wxglade.py \$*" >> wxglade
diff --git a/dev-util/wxglade/wxglade-0.5.ebuild b/dev-util/wxglade/wxglade-0.5.ebuild
deleted file mode 100644
index 7b3b5105adc8..000000000000
--- a/dev-util/wxglade/wxglade-0.5.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/wxglade-0.5.ebuild,v 1.1 2007/05/13 21:35:35 leio Exp $
-
-inherit python multilib eutils
-
-MY_P="wxGlade-${PV}"
-DESCRIPTION="Glade-like GUI designer which can generate Python, Perl, C++ or XRC code"
-HOMEPAGE="http://wxglade.sourceforge.net/"
-SRC_URI="mirror://sourceforge/wxglade/${MY_P}.tar.gz"
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
-S="${WORKDIR}/${MY_P}"
-DEPEND=">=dev-lang/python-2.3
- >=dev-python/wxpython-2.6"
-
-src_install() {
- python_version
- dodir /usr/lib/python${PYVER}/site-packages/${PN}
- dodoc CHANGES.txt README.txt TODO.txt credits.txt
- cp credits.txt ${D}/usr/lib/python${PYVER}/site-packages/${PN}/
- dohtml -r docs/*
- rm -rf docs *txt
- cp -R * ${D}/usr/lib/python${PYVER}/site-packages/${PN}/
- dosym /usr/share/doc/${PF}/html /usr/lib/python${PYVER}/site-packages/${PN}/docs
- echo "#!/bin/bash" > wxglade
- echo "exec python /usr/lib/python${PYVER}/site-packages/${PN}/wxglade.py \$*" >> wxglade
- exeinto /usr/bin
- doexe wxglade
- insinto /usr/share/pixmaps
- newins icons/icon.xpm wxglade.xpm
- make_desktop_entry wxglade wxGlade wxglade "Development;GUIDesigner"
-}
-
-pkg_postinst() {
- python_mod_optimize ${ROOT}usr/$(get_libdir)/python*/site-packages/wxglade
-}
-
-pkg_postrm() {
- python_mod_cleanup ${ROOT}usr/$(get_libdir)/python*/site-packages/wxglade
-}