summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-03-16 01:44:19 +0000
committerChristoph Junghans <ottxor@gentoo.org>2015-03-16 01:44:19 +0000
commit53d0821e82bdcde586e90a26c9b0692c231d2bcf (patch)
tree009c748fb5fd632d2ac527bc18d109b527666e22 /dev-util
parentalpha stable, bug 540868. (diff)
downloadgentoo-2-53d0821e82bdcde586e90a26c9b0692c231d2bcf.tar.gz
gentoo-2-53d0821e82bdcde586e90a26c9b0692c231d2bcf.tar.bz2
gentoo-2-53d0821e82bdcde586e90a26c9b0692c231d2bcf.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cwdiff/ChangeLog7
-rw-r--r--dev-util/cwdiff/cwdiff-0.3.0.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-util/cwdiff/ChangeLog b/dev-util/cwdiff/ChangeLog
index 7729aee3c4f9..e12713b0371b 100644
--- a/dev-util/cwdiff/ChangeLog
+++ b/dev-util/cwdiff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cwdiff
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cwdiff/ChangeLog,v 1.11 2015/03/13 20:13:48 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cwdiff/ChangeLog,v 1.12 2015/03/16 01:44:19 ottxor Exp $
+
+*cwdiff-0.3.0 (16 Mar 2015)
+
+ 16 Mar 2015; Christoph Junghans <ottxor@gentoo.org> +cwdiff-0.3.0.ebuild:
+ version bump
13 Mar 2015; Christoph Junghans <ottxor@gentoo.org> -cwdiff-0.2.5.ebuild,
-cwdiff-0.2.6.ebuild, -cwdiff-0.2.7.ebuild:
diff --git a/dev-util/cwdiff/cwdiff-0.3.0.ebuild b/dev-util/cwdiff/cwdiff-0.3.0.ebuild
new file mode 100644
index 000000000000..d351f2972f62
--- /dev/null
+++ b/dev-util/cwdiff/cwdiff-0.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cwdiff/cwdiff-0.3.0.ebuild,v 1.1 2015/03/16 01:44:19 ottxor Exp $
+
+EAPI=5
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/junghans/${PN}.git http://github.com/junghans/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/junghans/cwdiff/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x64-macos ~x86-macos"
+fi
+
+DESCRIPTION="A script that wraps wdiff to support directories and colorize the output"
+HOMEPAGE="https://github.com/junghans/cwdiff"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="a2ps mercurial"
+
+DEPEND="sys-apps/help2man
+ sys-apps/coreutils"
+RDEPEND="
+ sys-apps/sed
+ app-shells/bash
+ app-text/wdiff
+ sys-apps/diffutils
+ a2ps? ( app-text/a2ps )
+ mercurial? ( dev-vcs/mercurial )
+ "
+
+src_install() {
+ emake DESTDIR="${ED}" "$(usex mercurial '' 'HGRCDIR=')" install
+ dodoc README.md
+}