summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2015-06-02 16:59:12 +0000
committerFabian Groffen <grobian@gentoo.org>2015-06-02 16:59:12 +0000
commit7de231c87fade9538eb8aeb0208e7e934c5d2e4f (patch)
tree41400e11a102a48e55ca6e7afc523e8529555249 /dev-vcs
parentDisable tests connecting to the network, fixes Bug #550710 (diff)
downloadgentoo-2-7de231c87fade9538eb8aeb0208e7e934c5d2e4f.tar.gz
gentoo-2-7de231c87fade9538eb8aeb0208e7e934c5d2e4f.tar.bz2
gentoo-2-7de231c87fade9538eb8aeb0208e7e934c5d2e4f.zip
Version bump which works with >=mercurial-3.3.3, thanks Nico R in bug #549434
(Portage version: 2.2.14-prefix/cvs/Darwin i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/hg-git/ChangeLog8
-rw-r--r--dev-vcs/hg-git/hg-git-0.7.0.ebuild3
-rw-r--r--dev-vcs/hg-git/hg-git-0.8.0.ebuild3
-rw-r--r--dev-vcs/hg-git/hg-git-0.8.1.ebuild25
4 files changed, 36 insertions, 3 deletions
diff --git a/dev-vcs/hg-git/ChangeLog b/dev-vcs/hg-git/ChangeLog
index e0c65718966b..039b8448e6c2 100644
--- a/dev-vcs/hg-git/ChangeLog
+++ b/dev-vcs/hg-git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/hg-git
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/ChangeLog,v 1.62 2015/02/02 10:10:54 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/ChangeLog,v 1.63 2015/06/02 16:59:12 grobian Exp $
+
+*hg-git-0.8.1 (02 Jun 2015)
+
+ 02 Jun 2015; Fabian Groffen <grobian@gentoo.org> +hg-git-0.8.1.ebuild,
+ hg-git-0.7.0.ebuild, hg-git-0.8.0.ebuild:
+ Version bump which works with >=mercurial-3.3.3, thanks Nico R in bug #549434
*hg-git-0.8.0 (02 Feb 2015)
diff --git a/dev-vcs/hg-git/hg-git-0.7.0.ebuild b/dev-vcs/hg-git/hg-git-0.7.0.ebuild
index d8394bfcbda0..142ced7e4f01 100644
--- a/dev-vcs/hg-git/hg-git-0.7.0.ebuild
+++ b/dev-vcs/hg-git/hg-git-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/hg-git-0.7.0.ebuild,v 1.3 2015/01/26 09:44:46 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/hg-git-0.7.0.ebuild,v 1.4 2015/06/02 16:59:12 grobian Exp $
EAPI="5"
PYTHON_COMPAT=( python2_7 )
@@ -18,6 +18,7 @@ IUSE=""
RDEPEND="
>=dev-vcs/mercurial-1.9.3[${PYTHON_USEDEP}]
+ <dev-vcs/mercurial-3.3.3[${PYTHON_USEDEP}]
>=dev-python/dulwich-0.9.4[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
diff --git a/dev-vcs/hg-git/hg-git-0.8.0.ebuild b/dev-vcs/hg-git/hg-git-0.8.0.ebuild
index e6e665df1f46..e678cb80d056 100644
--- a/dev-vcs/hg-git/hg-git-0.8.0.ebuild
+++ b/dev-vcs/hg-git/hg-git-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/hg-git-0.8.0.ebuild,v 1.1 2015/02/02 10:10:54 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/hg-git-0.8.0.ebuild,v 1.2 2015/06/02 16:59:12 grobian Exp $
EAPI="5"
PYTHON_COMPAT=( python2_7 )
@@ -18,6 +18,7 @@ IUSE=""
RDEPEND="
>=dev-vcs/mercurial-1.9.3[${PYTHON_USEDEP}]
+ <dev-vcs/mercurial-3.3.3[${PYTHON_USEDEP}]
>=dev-python/dulwich-0.9.4[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
diff --git a/dev-vcs/hg-git/hg-git-0.8.1.ebuild b/dev-vcs/hg-git/hg-git-0.8.1.ebuild
new file mode 100644
index 000000000000..643915d40f0f
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-0.8.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-git/hg-git-0.8.1.ebuild,v 1.1 2015/06/02 16:59:12 grobian Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="push to and pull from a Git repository using Mercurial"
+HOMEPAGE="http://hg-git.github.io https://pypi.python.org/pypi/hg-git"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-vcs/mercurial-1.9.3[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.9.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"