summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-10-31 14:28:02 +0000
committerMichał Górny <mgorny@gentoo.org>2012-10-31 14:28:02 +0000
commitabc1dd65f510f45e113c0101ca8fa36f0c70312c (patch)
tree896e3bd2c04cea3f8d5115921fa4ce1eafa9e3a9 /eclass/distutils-r1.eclass
parentx86 stable, see bug 438750 (diff)
downloadgentoo-2-abc1dd65f510f45e113c0101ca8fa36f0c70312c.tar.gz
gentoo-2-abc1dd65f510f45e113c0101ca8fa36f0c70312c.tar.bz2
gentoo-2-abc1dd65f510f45e113c0101ca8fa36f0c70312c.zip
Enable byte-compilation of Python modules only locally for distutils-r1_python_install(). Thanks to Enlik for reminding me of it.
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass5
1 files changed, 3 insertions, 2 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 172cc70f39da..2944e7649aee 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.14 2012/10/29 13:34:02 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.15 2012/10/31 14:28:02 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -275,7 +275,8 @@ distutils-r1_python_install() {
esac
debug-print "${FUNCNAME}: [${EPYTHON}] flags: ${flags}"
- unset PYTHONDONTWRITEBYTECODE
+ # enable compilation for the install phase.
+ local PYTHONDONTWRITEBYTECODE=
esetup.py install "${flags[@]}" --root="${D}" "${@}"