summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-12-09 21:25:06 +0000
committerMike Frysinger <vapier@gentoo.org>2009-12-09 21:25:06 +0000
commit11cc6bd1f8631835b6b14d2a5d26d28839c8e1ce (patch)
tree6e3dcdecba15fb46948e2298dbb966bf819134a7 /eclass/toolchain.eclass
parentamd64/x86 stable, not amd64/amd64... (diff)
downloadgentoo-2-11cc6bd1f8631835b6b14d2a5d26d28839c8e1ce.tar.gz
gentoo-2-11cc6bd1f8631835b6b14d2a5d26d28839c8e1ce.tar.bz2
gentoo-2-11cc6bd1f8631835b6b14d2a5d26d28839c8e1ce.zip
revert previous commit; we want gcj pc file for both native and cross toolchains so *other packages* can find & link against gcj
Diffstat (limited to 'eclass/toolchain.eclass')
-rw-r--r--eclass/toolchain.eclass13
1 files changed, 4 insertions, 9 deletions
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index 67ac91654922..06f0b98e28c1 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.411 2009/12/04 15:00:47 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.412 2009/12/09 21:25:06 vapier Exp $
#
# Maintainer: Toolchain Ninjas <toolchain@gentoo.org>
@@ -1920,16 +1920,11 @@ gcc_slot_java() {
[[ -f ${D}${PREFIX}/lib/libgcj.spec ]] && \
mv -f "${D}"${PREFIX}/lib/libgcj.spec "${D}"${LIBPATH}/libgcj.spec
+ # SLOT up libgcj.pc (and let gcc-config worry about links)
local libgcj=$(find "${D}"${PREFIX}/lib/pkgconfig/ -name 'libgcj*.pc')
if [[ -n ${libgcj} ]] ; then
- if is_crosscompile ; then
- # Simply remove the libgcj.pc file for cross-compilers
- rm "${libgcj}" || die
- else
- # SLOT up libgcj.pc (and let gcc-config worry about links)
- sed -i "/^libdir=/s:=.*:=${LIBPATH}:" "${libgcj}"
- mv "${libgcj}" "${D}"/usr/lib/pkgconfig/libgcj-${GCC_PV}.pc || die
- fi
+ sed -i "/^libdir=/s:=.*:=${LIBPATH}:" "${libgcj}"
+ mv "${libgcj}" "${D}"/usr/lib/pkgconfig/libgcj-${GCC_PV}.pc || die
fi
# Rename jar because it could clash with Kaffe's jar if this gcc is