summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-05-29 18:46:08 +0000
committerMarien Zwart <marienz@gentoo.org>2006-05-29 18:46:08 +0000
commit87c660b9c7c0fe7eed4f1717d7705dcb7cbd6f0b (patch)
treef7b06920db2f19ebd03a7f56ffedfb21de2eedf3 /eclass/twisted.eclass
parent~amd64 (diff)
downloadgentoo-2-87c660b9c7c0fe7eed4f1717d7705dcb7cbd6f0b.tar.gz
gentoo-2-87c660b9c7c0fe7eed4f1717d7705dcb7cbd6f0b.tar.bz2
gentoo-2-87c660b9c7c0fe7eed4f1717d7705dcb7cbd6f0b.zip
Stop the tests from breaking on up- and downgrades. Thanks to blubb for reporting.
Diffstat (limited to 'eclass/twisted.eclass')
-rw-r--r--eclass/twisted.eclass13
1 files changed, 12 insertions, 1 deletions
diff --git a/eclass/twisted.eclass b/eclass/twisted.eclass
index 1792c2c9f33c..615546781788 100644
--- a/eclass/twisted.eclass
+++ b/eclass/twisted.eclass
@@ -1,6 +1,6 @@
# Copyright 2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/eclass/twisted.eclass,v 1.5 2006/05/16 16:52:49 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/twisted.eclass,v 1.6 2006/05/29 18:46:08 marienz Exp $
#
# Author: Marien Zwart <marienz@gentoo.org>
#
@@ -8,6 +8,9 @@
#
# you should set MY_PACKAGE to something like 'Names' before inheriting.
# you may set MY_PV to the right version (defaults to PV).
+#
+# twisted_src_test relies on the package installing twisted.names to
+# have a ${PN} of twisted-names.
inherit distutils versionator eutils
@@ -33,6 +36,14 @@ twisted_src_test() {
local spath="usr/$(get_libdir)/python${PYVER}/site-packages/"
mkdir -p "${T}/${spath}"
cp -R "${ROOT}${spath}/twisted" "${T}/${spath}" || die
+
+ # We have to get rid of the existing version of this package
+ # instead of just installing on top of it, since if the existing
+ # package has tests in files the version we are installing does
+ # not have we end up running fex twisted-names-0.3.0 tests when
+ # downgrading to twisted-names-0.1.0-r1.
+ rm -rf "${T}/${spath}/${PN/-//}"
+
if has_version ">=dev-lang/python-2.3"; then
"${python}" setup.py install --root="${T}" --no-compile --force \
--install-lib="${spath}" || die