summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-01-12 23:18:20 +0000
committerMichał Górny <mgorny@gentoo.org>2013-01-12 23:18:20 +0000
commite04ccee57853a1afd8376b0baad16afa6be3f93b (patch)
treefee6fb7f873ec2773588223456ebff4aac6b6113 /eclass
parentPass arguments to setup.py in an predictable order, especially do not prepend... (diff)
downloadgentoo-2-e04ccee57853a1afd8376b0baad16afa6be3f93b.tar.gz
gentoo-2-e04ccee57853a1afd8376b0baad16afa6be3f93b.tar.bz2
gentoo-2-e04ccee57853a1afd8376b0baad16afa6be3f93b.zip
Provide best implementation's build dir in python_*_all() as BUILD_DIR to make use of esetup.py easier.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog6
-rw-r--r--eclass/distutils-r1.eclass6
2 files changed, 9 insertions, 3 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index cd3262124fbb..0ebf5e892ba4 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for eclass directory
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.612 2013/01/12 23:17:22 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.613 2013/01/12 23:18:20 mgorny Exp $
+
+ 12 Jan 2013; Michał Górny <mgorny@gentoo.org> distutils-r1.eclass:
+ Provide best implementation's build dir in python_*_all() as BUILD_DIR to
+ make use of esetup.py easier.
12 Jan 2013; Michał Górny <mgorny@gentoo.org> distutils-r1.eclass:
Pass arguments to setup.py in an predictable order, especially do not prepend
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index aa5b8cef66b9..7d61166acb5e 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.43 2013/01/12 23:17:22 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.44 2013/01/12 23:18:20 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -451,9 +451,11 @@ distutils-r1_run_phase() {
# @DESCRIPTION:
# Run the given command, restoring the best-implementation state.
_distutils-r1_run_common_phase() {
+ local DISTUTILS_ORIG_BUILD_DIR=${BUILD_DIR}
+
local EPYTHON=${_DISTUTILS_BEST_IMPL[0]}
local PYTHON=${_DISTUTILS_BEST_IMPL[1]}
- local BEST_BUILD_DIR=${_DISTUTILS_BEST_IMPL[2]}
+ local BUILD_DIR=${_DISTUTILS_BEST_IMPL[2]}
local PYTHONPATH=${_DISTUTILS_BEST_IMPL[3]}
export EPYTHON PYTHON PYTHONPATH