summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-19 16:22:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-19 16:22:47 +0000
commit03eaf448046c85cb57f1ee71f6d079aa9bcd8a4c (patch)
tree4501b25c7d46487f0d2f41a0da2635ab628aee94 /games-action/wordwarvi
parentAdded patch to fix compilation with --as-needed. Closes bug #248652. (diff)
downloadgentoo-2-03eaf448046c85cb57f1ee71f6d079aa9bcd8a4c.tar.gz
gentoo-2-03eaf448046c85cb57f1ee71f6d079aa9bcd8a4c.tar.bz2
gentoo-2-03eaf448046c85cb57f1ee71f6d079aa9bcd8a4c.zip
version bump
(Portage version: 2.1.6.4/cvs/Linux 2.6.27.8 i686)
Diffstat (limited to 'games-action/wordwarvi')
-rw-r--r--games-action/wordwarvi/ChangeLog10
-rw-r--r--games-action/wordwarvi/wordwarvi-0.25.ebuild55
2 files changed, 63 insertions, 2 deletions
diff --git a/games-action/wordwarvi/ChangeLog b/games-action/wordwarvi/ChangeLog
index a22d4210602a..f2118f7d9464 100644
--- a/games-action/wordwarvi/ChangeLog
+++ b/games-action/wordwarvi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/wordwarvi
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/wordwarvi/ChangeLog,v 1.3 2008/12/14 10:57:31 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/wordwarvi/ChangeLog,v 1.4 2009/01/19 16:22:47 mr_bones_ Exp $
+
+*wordwarvi-0.25 (19 Jan 2009)
+
+ 19 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +wordwarvi-0.25.ebuild:
+ version bump
*wordwarvi-0.24 (14 Dec 2008)
diff --git a/games-action/wordwarvi/wordwarvi-0.25.ebuild b/games-action/wordwarvi/wordwarvi-0.25.ebuild
new file mode 100644
index 000000000000..97e91c13b137
--- /dev/null
+++ b/games-action/wordwarvi/wordwarvi-0.25.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/wordwarvi/wordwarvi-0.25.ebuild,v 1.1 2009/01/19 16:22:47 mr_bones_ Exp $
+
+EAPI=1
+inherit eutils games
+
+DESCRIPTION="A retro side-scrolling shoot'em up based on the editor war story"
+HOMEPAGE="http://wordwarvi.sourceforge.net"
+SRC_URI="mirror://sourceforge/wordwarvi/${P}.tar.gz"
+
+LICENSE="GPL-2 CCPL-Attribution-2.0 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vorbis"
+
+RDEPEND="x11-libs/gtk+:2
+ vorbis? ( media-libs/libvorbis
+ >=media-libs/portaudio-19_pre1 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^DATADIR/s/=/?=/' \
+ -e '/^OPTIMIZE_FLAG/s/=.*/=$(CFLAGS)/' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake \
+ PREFIX="${GAMES_PREFIX}" \
+ DATADIR="${GAMES_DATADIR}/${PN}" \
+ MANDIR="/usr/share/man" \
+ WITHAUDIO=$(use vorbis && echo yes || echo no) all \
+ || die "emake failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${GAMES_PREFIX}" \
+ DATADIR="${GAMES_DATADIR}/${PN}" \
+ MANDIR="/usr/share/man" \
+ WITHAUDIO=$(use vorbis && echo yes || echo no) all \
+ install || die "emake install failed"
+ use vorbis || rm -rf "${D}${GAMES_DATADIR}/${PN}"
+ dodoc README AUTHORS changelog.txt AAA_HOW_TO_MAKE_NEW_LEVELS.txt
+ newicon icons/wordwarvi_icon_128x128.png ${PN}.png
+ make_desktop_entry ${PN} "Word War vi"
+ prepgamesdirs
+}