summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-07 08:43:21 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-07 08:43:21 +0000
commiteb02ec358a481d31f35665e3ad7ca17dc9528b98 (patch)
tree8f4bf27e2fef88553a6d82808b2fb7751e7f9ef8 /games-action
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-eb02ec358a481d31f35665e3ad7ca17dc9528b98.tar.gz
gentoo-2-eb02ec358a481d31f35665e3ad7ca17dc9528b98.tar.bz2
gentoo-2-eb02ec358a481d31f35665e3ad7ca17dc9528b98.zip
Respect LDFLAGS. Bug #339896
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/rafkill/ChangeLog8
-rw-r--r--games-action/rafkill/files/rafkill-1.2.3-ldflags.patch17
-rw-r--r--games-action/rafkill/rafkill-1.2.3.ebuild7
3 files changed, 27 insertions, 5 deletions
diff --git a/games-action/rafkill/ChangeLog b/games-action/rafkill/ChangeLog
index 0099aabd6a51..6e6159793b0a 100644
--- a/games-action/rafkill/ChangeLog
+++ b/games-action/rafkill/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/rafkill
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/rafkill/ChangeLog,v 1.5 2008/04/30 16:46:31 nyhm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/rafkill/ChangeLog,v 1.6 2010/10/07 08:43:21 tupone Exp $
+
+ 07 Oct 2010; Alfredo Tupone <tupone@gentoo.org> rafkill-1.2.3.ebuild,
+ +files/rafkill-1.2.3-ldflags.patch:
+ Respect LDFLAGS. Bug #339896 by flameeyes@gentoo.org
30 Apr 2008; Tristan Heaven <nyhm@gentoo.org>
+files/rafkill-1.2.3-gcc43.patch, rafkill-1.2.3.ebuild:
diff --git a/games-action/rafkill/files/rafkill-1.2.3-ldflags.patch b/games-action/rafkill/files/rafkill-1.2.3-ldflags.patch
new file mode 100644
index 000000000000..5c6be0955484
--- /dev/null
+++ b/games-action/rafkill/files/rafkill-1.2.3-ldflags.patch
@@ -0,0 +1,17 @@
+--- SConstruct.old 2010-10-07 10:37:26.000000000 +0200
++++ SConstruct 2010-10-07 10:39:33.000000000 +0200
+@@ -1,5 +1,6 @@
+ import os
+ import sys
++import SCons.Util
+
+ env = Environment( ENV = os.environ );
+ config = env.Configure();
+@@ -36,6 +37,7 @@
+
+ env.BuildDir( 'build/', 'src/' )
+ env.Append( LIBS = [ 'aldmb', 'dumb' ] );
++env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
+ if sys.platform == 'win32':
+ env.Append( CCFLAGS = [ '-DWINDOWS' ] )
+ env.Append( LIBS = [ 'alleg', 'pthreadGC2' ] )
diff --git a/games-action/rafkill/rafkill-1.2.3.ebuild b/games-action/rafkill/rafkill-1.2.3.ebuild
index 1da96157efbf..663aafec48c7 100644
--- a/games-action/rafkill/rafkill-1.2.3.ebuild
+++ b/games-action/rafkill/rafkill-1.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/rafkill/rafkill-1.2.3.ebuild,v 1.4 2009/11/23 01:40:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/rafkill/rafkill-1.2.3.ebuild,v 1.5 2010/10/07 08:43:21 tupone Exp $
EAPI=2
inherit eutils toolchain-funcs games
@@ -23,7 +23,8 @@ src_prepare() {
rm -f {data,music}/.sconsign
epatch \
"${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
sed -i \
-e "/^#define INSTALL_DIR/s:\.:${GAMES_DATADIR}:" \
src/defs.cpp \