summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-04-21 10:39:15 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-04-21 10:39:15 +0000
commit3eeaa7a7873f8f0fe830a558cbe2042f0356e749 (patch)
treee5de093e516dcb00cc38c425df6d70ebbcad0d73 /games-arcade/sable
parentia64 stable (diff)
downloadgentoo-2-3eeaa7a7873f8f0fe830a558cbe2042f0356e749.tar.gz
gentoo-2-3eeaa7a7873f8f0fe830a558cbe2042f0356e749.tar.bz2
gentoo-2-3eeaa7a7873f8f0fe830a558cbe2042f0356e749.zip
inherit eutils
(Portage version: 2.1.2.4)
Diffstat (limited to 'games-arcade/sable')
-rw-r--r--games-arcade/sable/sable-1.0.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/games-arcade/sable/sable-1.0.ebuild b/games-arcade/sable/sable-1.0.ebuild
index 4517e59fc33b..57f9cc2eb35e 100644
--- a/games-arcade/sable/sable-1.0.ebuild
+++ b/games-arcade/sable/sable-1.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sable/sable-1.0.ebuild,v 1.3 2007/04/16 21:12:31 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sable/sable-1.0.ebuild,v 1.4 2007/04/21 10:39:15 nyhm Exp $
-inherit games
+inherit eutils games
-DESCRIPTION="A frantic 3d space shooter."
+DESCRIPTION="A frantic 3D space shooter"
HOMEPAGE="http://www.stanford.edu/~mcmartin/sable/"
SRC_URI="http://www.stanford.edu/~mcmartin/${PN}/${P}-src.tgz
mirror://gentoo/${PN}.png"
@@ -22,17 +22,17 @@ DEPEND="virtual/opengl
S=${WORKDIR}/${PN}
src_compile() {
- emake INSTALL_RESDIR=${GAMES_DATADIR} || die "emake failed"
+ emake INSTALL_RESDIR="${GAMES_DATADIR}" || die "emake failed"
}
src_install() {
- dogamesbin ${PN} || die "Install binary failed"
- insinto "$GAMES_DATADIR/${PN}"
- doins -r models sfx textures || die "Install data files failes"
- dodoc README || die "Install doc failed"
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r models sfx textures || die "doins failed"
+ dodoc ChangeLog README
doicon "${DISTDIR}"/${PN}.png
- make_desktop_entry ${PN} ${PN}
+ make_desktop_entry ${PN} Sable
prepgamesdirs
}