summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-03 06:35:33 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-03 06:35:33 +0000
commit6cc35e3055d2d37568bfdc8a0d217207beab5769 (patch)
tree9d83b01cc79890fcc6a23b4128708d6b771ca465 /games-arcade/smclone
parentVersion bump. (diff)
downloadgentoo-2-6cc35e3055d2d37568bfdc8a0d217207beab5769.tar.gz
gentoo-2-6cc35e3055d2d37568bfdc8a0d217207beab5769.tar.bz2
gentoo-2-6cc35e3055d2d37568bfdc8a0d217207beab5769.zip
Version bump #87663 by Hans Cats.
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-arcade/smclone')
-rw-r--r--games-arcade/smclone/ChangeLog9
-rw-r--r--games-arcade/smclone/files/digest-smclone-0.952
-rw-r--r--games-arcade/smclone/files/smclone-0.95-gentoo-paths.patch15
-rw-r--r--games-arcade/smclone/files/smclone-0.95-use-HOME.patch50
-rw-r--r--games-arcade/smclone/smclone-0.95.ebuild60
5 files changed, 135 insertions, 1 deletions
diff --git a/games-arcade/smclone/ChangeLog b/games-arcade/smclone/ChangeLog
index 63f022c0f7a2..f1f0feb3681d 100644
--- a/games-arcade/smclone/ChangeLog
+++ b/games-arcade/smclone/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-arcade/smclone
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/smclone/ChangeLog,v 1.2 2005/02/08 23:18:08 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/smclone/ChangeLog,v 1.3 2005/04/03 06:35:33 vapier Exp $
+
+*smclone-0.95 (03 Apr 2005)
+
+ 03 Apr 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/smclone-0.95-gentoo-paths.patch,
+ +files/smclone-0.95-use-HOME.patch, +smclone-0.95.ebuild:
+ Version bump #87663 by Hans Cats.
08 Feb 2005; Chris Gianelloni <wolf31o2@gentoo.org> smclone-0.94.1.ebuild:
Adding amd64 to KEYWORDS and closing bug #79382.
diff --git a/games-arcade/smclone/files/digest-smclone-0.95 b/games-arcade/smclone/files/digest-smclone-0.95
new file mode 100644
index 000000000000..edb6ef24c928
--- /dev/null
+++ b/games-arcade/smclone/files/digest-smclone-0.95
@@ -0,0 +1,2 @@
+MD5 c35e017d9c9c7dd6144d38152060ec03 SMC_0.95.zip 4747150
+MD5 eb4f325dedb9da34049fd727bbf2a1e2 music_2.0_RC_1.zip 17954786
diff --git a/games-arcade/smclone/files/smclone-0.95-gentoo-paths.patch b/games-arcade/smclone/files/smclone-0.95-gentoo-paths.patch
new file mode 100644
index 000000000000..7b8b0147677a
--- /dev/null
+++ b/games-arcade/smclone/files/smclone-0.95-gentoo-paths.patch
@@ -0,0 +1,15 @@
+--- configure.ac
++++ configure.ac
+@@ -81,6 +81,6 @@
+-AC_DEFINE_UNQUOTED(LEVEL_DIR, "levels", [Directory for level files])
+-AC_DEFINE_UNQUOTED(OVERWORLD_DIR, "world", [Directory for word data])
+-AC_DEFINE_UNQUOTED(PIXMAPS_DIR, "data/pixmaps", [Directory for pixmap data])
+-AC_DEFINE_UNQUOTED(SOUNDS_DIR, "data/sounds", [Directory for sound data])
+-AC_DEFINE_UNQUOTED(MUSIC_DIR, "data/music", [Directory for music data])
+-AC_DEFINE_UNQUOTED(FONT_DIR, "data/font", [Directory for font data])
++AC_DEFINE_UNQUOTED(LEVEL_DIR, "@GENTOO_DATADIR@/levels", [Directory for level files])
++AC_DEFINE_UNQUOTED(OVERWORLD_DIR, "@GENTOO_DATADIR@/world", [Directory for word data])
++AC_DEFINE_UNQUOTED(PIXMAPS_DIR, "@GENTOO_DATADIR@/pixmaps", [Directory for pixmap data])
++AC_DEFINE_UNQUOTED(SOUNDS_DIR, "@GENTOO_DATADIR@/sounds", [Directory for sound data])
++AC_DEFINE_UNQUOTED(MUSIC_DIR, "@GENTOO_DATADIR@/music", [Directory for music data])
++AC_DEFINE_UNQUOTED(FONT_DIR, "@GENTOO_DATADIR@/font", [Directory for font data])
diff --git a/games-arcade/smclone/files/smclone-0.95-use-HOME.patch b/games-arcade/smclone/files/smclone-0.95-use-HOME.patch
new file mode 100644
index 000000000000..114ae3a49385
--- /dev/null
+++ b/games-arcade/smclone/files/smclone-0.95-use-HOME.patch
@@ -0,0 +1,50 @@
+--- savegame.cpp
++++ savegame.cpp
+@@ -45,8 +45,8 @@
+ loaded_save_info.OW_world = 0;
+ loaded_save_info.itembox_item = 0;
+
+- char Full_Save_Name[40];
+- sprintf( Full_Save_Name, "%s/%d.sav", SAVE_DIR, Save_file );
++ char Full_Save_Name[255];
++ snprintf( Full_Save_Name, sizeof(Full_Save_Name) - 1, "%s/.smclone/%d.sav", getenv("HOME"), Save_file );
+
+ ifstream ifs( Full_Save_Name, ios::in );
+
+@@ -79,8 +79,8 @@
+
+ int cSavegame :: Save( unsigned int Save_file, Savegame Save_info )
+ {
+- char Full_Save_Name[45];
+- sprintf( Full_Save_Name, "%s/%d.sav", SAVE_DIR, Save_file );
++ char Full_Save_Name[255];
++ snprintf( Full_Save_Name, sizeof(Full_Save_Name) - 1, "%s/.smclone/%d.sav", getenv("HOME"), Save_file );
+
+ ifstream ifs( Full_Save_Name, ios::in );
+
+@@ -181,10 +181,11 @@
+ char buffer[10];
+ char desc_tmp[150];
+
+- Full_Save_Name = SAVE_DIR "/.sav";
++ Full_Save_Name = "/.smclone/.sav";
+
+ sprintf( buffer, "%d", Save_file );
+- Full_Save_Name.insert( strlen( SAVE_DIR ) + 1, buffer );
++ Full_Save_Name.insert( strlen( "/.smclone/" ) + 1, buffer );
++ Full_Save_Name.insert( 0, getenv("HOME") );
+
+ if( !valid_file( Full_Save_Name ) )
+ {
+@@ -235,9 +236,9 @@
+
+ bool cSavegame :: is_valid( unsigned int Save_file )
+ {
+- char savename[50];
++ char savename[255];
+
+- sprintf( savename, "%s/%d.sav", SAVE_DIR, Save_file );
++ snprintf( savename, sizeof(savename) - 1, "%s/.smclone/%d.sav", getenv("HOME"), Save_file );
+
+ return valid_file( savename );
+ }
diff --git a/games-arcade/smclone/smclone-0.95.ebuild b/games-arcade/smclone/smclone-0.95.ebuild
new file mode 100644
index 000000000000..7ab1411670b1
--- /dev/null
+++ b/games-arcade/smclone/smclone-0.95.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/smclone/smclone-0.95.ebuild,v 1.1 2005/04/03 06:35:33 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="clone of Super Mario World"
+HOMEPAGE="http://smclone.arturh.com/"
+SRC_URI="mirror://sourceforge/smclone/SMC_${PV}.zip
+ mirror://sourceforge/smclone/music_2.0_RC_1.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-gfx"
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.51"
+
+S="${WORKDIR}/SMC 0.95 Preview 1"
+
+src_unpack() {
+ unpack SMC_${PV}.zip
+ cd "${S}"
+ unpack music_2.0_RC_1.zip
+
+ find . '(' -name '*.dll' -o -name '*.exe' ')' -exec rm {} \;
+ cd src/unix
+ chmod go+rw *
+ edos2unix Makefile.am autogen.sh configure.ac ../savegame.cpp
+ epatch "${FILESDIR}"/${P}-gentoo-paths.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:g" \
+ configure.ac
+ chmod a+x autogen.sh
+ ./autogen.sh || die "autogen failed"
+ cd ..
+ epatch "${FILESDIR}"/${P}-use-HOME.patch
+}
+
+src_compile() {
+ cd src/unix
+ egamesconf || die
+ emake || die
+}
+
+src_install() {
+ dogamesbin src/unix/smc || die "smc"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data levels world || die "doins"
+ dodoc *.txt ../readme-linux.txt
+ cd ..
+ dohtml *.html *.css
+ prepgamesdirs
+}