summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-05-07 19:28:53 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-05-07 19:28:53 +0000
commitfab150a2347739e6731aac4de2e405ca6b87a9e7 (patch)
tree724a276c7c58869cce621168ac94288b412b1006 /games-board
parentFix digest (diff)
downloadgentoo-2-fab150a2347739e6731aac4de2e405ca6b87a9e7.tar.gz
gentoo-2-fab150a2347739e6731aac4de2e405ca6b87a9e7.tar.bz2
gentoo-2-fab150a2347739e6731aac4de2e405ca6b87a9e7.zip
Version bump to 4.3 Bug #410303
(Portage version: 2.1.10.57/cvs/Linux i686)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/scid/ChangeLog8
-rw-r--r--games-board/scid/files/scid-4.3-gentoo.patch79
-rw-r--r--games-board/scid/files/scid-4.3-parallelmake.patch11
-rw-r--r--games-board/scid/scid-4.3.ebuild95
4 files changed, 192 insertions, 1 deletions
diff --git a/games-board/scid/ChangeLog b/games-board/scid/ChangeLog
index 6479b050ce7e..a450cbaec515 100644
--- a/games-board/scid/ChangeLog
+++ b/games-board/scid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/scid
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/scid/ChangeLog,v 1.32 2012/02/22 13:54:59 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/scid/ChangeLog,v 1.33 2012/05/07 19:28:53 tupone Exp $
+
+*scid-4.3 (07 May 2012)
+
+ 07 May 2012; Tupone Alfredo <tupone@gentoo.org> +scid-4.3.ebuild,
+ +files/scid-4.3-gentoo.patch, +files/scid-4.3-parallelmake.patch:
+ Version bump to 4.3 Bug #410303 by nihil39
22 Feb 2012; Tupone Alfredo <tupone@gentoo.org> scid-4.2.2.ebuild,
+files/scid-4.2.2-parallelmake.patch:
diff --git a/games-board/scid/files/scid-4.3-gentoo.patch b/games-board/scid/files/scid-4.3-gentoo.patch
new file mode 100644
index 000000000000..d700e58d997b
--- /dev/null
+++ b/games-board/scid/files/scid-4.3-gentoo.patch
@@ -0,0 +1,79 @@
+--- engines/togaII1.2.1a/src/Makefile.old 2012-05-06 20:56:56.190522872 +0200
++++ engines/togaII1.2.1a/src/Makefile 2012-05-06 20:58:20.995568403 +0200
+@@ -18,23 +18,16 @@
+
+ # general
+
+-CXX = g++
+-CXXFLAGS = -pipe -Wall
+-LDFLAGS = -lm
+
+ # C++
+
+-CXXFLAGS += -fno-exceptions -fno-rtti
+
+ # optimisation
+
+-CXXFLAGS += -O3 -fstrict-aliasing
+-CXXFLAGS += -fomit-frame-pointer
+ # CXXFLAGS += -march=athlon-xp # SELECT ME
+
+ # strip
+
+-LDFLAGS += -s
+
+ # dependencies
+
+--- tcl/config.tcl.old 2012-05-06 20:59:24.475111275 +0200
++++ tcl/config.tcl 2012-05-06 21:03:04.075692323 +0200
+@@ -5,7 +5,7 @@
+ if {$windowsOS} {
+ set scidShareDir $scidExeDir
+ } else {
+- set scidShareDir [file normalize [file join $scidExeDir "../share/scid"]]
++ set scidShareDir "@GENTOO_DATADIR@"
+ }
+
+ if {![info exists scidBooksDir]} {
+--- tcl/start.tcl.old 2012-05-06 21:03:43.770905179 +0200
++++ tcl/start.tcl 2012-05-06 21:04:51.429154649 +0200
+@@ -993,7 +993,7 @@
+
+ ### Audio move announcement options:
+
+-set ::utils::sound::soundFolder [file nativename [file join $::scidExeDir sounds]]
++set ::utils::sound::soundFolder "@GENTOO_DATADIR@/sounds"
+ set ::utils::sound::announceNew 0
+ set ::utils::sound::announceForward 0
+ set ::utils::sound::announceBack 0
+@@ -1002,7 +1002,7 @@
+ if {$windowsOS} {
+ set spellCheckFile [file join $scidDataDir "spelling.ssp"]
+ } else {
+- set spellCheckFile "/usr/local/share/scid/spelling.ssp"
++ set spellCheckFile "@GENTOO_DATADIR@/spelling.ssp"
+ }
+
+ # book configuration
+--- tcl/utils/sound.tcl.old 2012-05-06 21:05:31.475342861 +0200
++++ tcl/utils/sound.tcl 2012-05-06 21:06:07.066843851 +0200
+@@ -41,7 +41,7 @@
+ variable soundFolder
+
+ ::splash::add "Setting up audio move announcement..."
+- if {[catch {package require snack 2.0}]} {
++ if {[catch {package require snack}]} {
+ set hasSnackPackage 0
+ ::splash::add " Move speech disabled - Snack sound package not found"
+ return
+--- Makefile.conf.old 2012-05-06 21:06:39.825543746 +0200
++++ Makefile.conf 2012-05-06 21:07:22.668535585 +0200
+@@ -212,7 +212,7 @@
+ # Small extra programs. Most are written in Tcl using tcscid, but
+ # a few contributed ones may be in Python or other languages.
+ #
+-SCRIPTS= sc_addmove sc_epgn sc_spell sc_eco sc_import sc_remote sc_tree scidpgn pgnfix spliteco spf2spi
++SCRIPTS= sc_addmove sc_epgn sc_spell sc_eco sc_import sc_remote sc_tree scidpgn pgnfix eco2pgn spliteco spf2spi
+
+ ####################
+
diff --git a/games-board/scid/files/scid-4.3-parallelmake.patch b/games-board/scid/files/scid-4.3-parallelmake.patch
new file mode 100644
index 000000000000..e5bcae6c9cde
--- /dev/null
+++ b/games-board/scid/files/scid-4.3-parallelmake.patch
@@ -0,0 +1,11 @@
+--- Makefile.conf.old 2012-02-22 14:12:51.280071808 +0100
++++ Makefile.conf 2012-02-22 14:13:15.432372323 +0100
+@@ -379,7 +379,7 @@
+
+ scmerge: src/scmerge.o src/misc.o src/index.o src/date.o src/namebase.o \
+ src/gfile.o src/bytebuf.o src/textbuf.o src/myassert.o \
+- src/stralloc.o src/position.o
++ src/stralloc.o src/position.o $(OBJS)
+ $(LINK) -o scmerge src/scmerge.o $(OBJS) $(ZLIB) $(TCL_LIBRARY)
+
+ pgnscid: src/pgnscid.o $(OBJS)
diff --git a/games-board/scid/scid-4.3.ebuild b/games-board/scid/scid-4.3.ebuild
new file mode 100644
index 000000000000..166169a5fc1b
--- /dev/null
+++ b/games-board/scid/scid-4.3.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/scid/scid-4.3.ebuild,v 1.1 2012/05/07 19:28:53 tupone Exp $
+
+EAPI=2
+PYTHON_DEPEND="2"
+inherit eutils toolchain-funcs python games
+
+DESCRIPTION="a free chess database application"
+HOMEPAGE="http://scid.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scid/${P}.tar.bz2
+ mirror://sourceforge/scid/spelling.zip
+ mirror://sourceforge/scid/ratings.zip
+ mirror://sourceforge/scid/photos.zip
+ mirror://sourceforge/scid/scidlet40k.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="=dev-lang/tk-8.5*
+ >=sys-libs/zlib-1.1.3
+ app-arch/unzip"
+RDEPEND="${DEPEND}
+ !games-board/chessdb"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}
+
+src_prepare() {
+ edos2unix engines/togaII1.2.1a/src/Makefile
+ epatch "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-parallelmake.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ tcl/config.tcl \
+ tcl/start.tcl \
+ src/scidlet.cpp \
+ || die "sed failed"
+ gzip ../ratings.ssp
+ python_convert_shebangs -r 2 .
+}
+
+src_configure() {
+ # configure is not an autotools script
+ ./configure \
+ COMPILE=$(tc-getCXX) \
+ LINK="$(tc-getCXX) ${LDFLAGS}" \
+ CC=$(tc-getCC) \
+ OPTIMIZE="${CXXFLAGS}" \
+ TCL_INCLUDE="" \
+ BINDIR="${GAMES_BINDIR}" \
+ SHAREDIR="${GAMES_DATADIR}/${PN}" \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake all_scid || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install_scid || die "emake install failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r sounds || die "failed installing sounds"
+
+ dodoc CHANGES ChangeLog README THANKS TODO
+ dohtml help/*.html
+
+ newicon svg/scid_app.svg ${PN}.svg
+ make_desktop_entry scid Scid
+
+ cd ..
+ doins spelling.ssp \
+ || die "Failed installing spelling.ssp"
+ doins ratings.ssp.gz \
+ || die "Failed installing ratings.ssp"
+ doins *.spf \
+ || die "Failed installing photos"
+ newins scidlet40k.sbk scidlet.sbk \
+ || die "Failed installing scidlet.sbk"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To enable speech, emerge dev-tcltk/snack"
+ elog "To enable some piece sets, emerge dev-tcltk/tkimg"
+ elog "To enable Xfcc support, emerge dev-tcltk/tdom"
+}