summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-14 16:58:32 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-14 16:58:32 +0000
commit6d416f11811d79d007f0d438e1fb0308753aef9d (patch)
treeb257af097b726e5878712aa6aac7eb61bb12d93b /games-emulation/openmsx
parentVersion bump (diff)
downloadgentoo-2-6d416f11811d79d007f0d438e1fb0308753aef9d.tar.gz
gentoo-2-6d416f11811d79d007f0d438e1fb0308753aef9d.tar.bz2
gentoo-2-6d416f11811d79d007f0d438e1fb0308753aef9d.zip
Fix building with libpng15 wrt #378171 by Diego Elio Pettenò
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation/openmsx')
-rw-r--r--games-emulation/openmsx/ChangeLog6
-rw-r--r--games-emulation/openmsx/files/openmsx-0.8.1-libpng15.patch13
-rw-r--r--games-emulation/openmsx/openmsx-0.8.1.ebuild6
3 files changed, 22 insertions, 3 deletions
diff --git a/games-emulation/openmsx/ChangeLog b/games-emulation/openmsx/ChangeLog
index 7567a72c49c7..e6c1d24c5bbe 100644
--- a/games-emulation/openmsx/ChangeLog
+++ b/games-emulation/openmsx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/openmsx
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/ChangeLog,v 1.40 2011/08/24 19:38:57 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/ChangeLog,v 1.41 2011/09/14 16:58:32 ssuominen Exp $
+
+ 14 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> openmsx-0.8.1.ebuild,
+ +files/openmsx-0.8.1-libpng15.patch:
+ Fix building with libpng15 wrt #378171 by Diego Elio Pettenò
24 Aug 2011; Markus Meier <maekke@gentoo.org> openmsx-0.8.1.ebuild:
x86 stable, bug #380179
diff --git a/games-emulation/openmsx/files/openmsx-0.8.1-libpng15.patch b/games-emulation/openmsx/files/openmsx-0.8.1-libpng15.patch
new file mode 100644
index 000000000000..46f13a0fbc84
--- /dev/null
+++ b/games-emulation/openmsx/files/openmsx-0.8.1-libpng15.patch
@@ -0,0 +1,13 @@
+http://openmsx.svn.sourceforge.net/viewvc/openmsx/openmsx/trunk/src/video/PNG.cc?r1=11609&r2=12214
+
+--- src/video/PNG.cc
++++ src/video/PNG.cc
+@@ -167,7 +167,7 @@
+ "Attempted to create a surface with excessive height: "
+ << height << ", max " << MAX_SIZE);
+ }
+- int bpp = png.info->channels * 8;
++ int bpp = png_get_channels(png.ptr, png.info) * 8;
+ assert(bpp == 24 || bpp == 32);
+ Uint32 redMask, grnMask, bluMask, alpMask;
+ if (OPENMSX_BIGENDIAN) {
diff --git a/games-emulation/openmsx/openmsx-0.8.1.ebuild b/games-emulation/openmsx/openmsx-0.8.1.ebuild
index d6f25f378901..2c8c35019521 100644
--- a/games-emulation/openmsx/openmsx-0.8.1.ebuild
+++ b/games-emulation/openmsx/openmsx-0.8.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/openmsx-0.8.1.ebuild,v 1.3 2011/08/24 19:38:57 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/openmsx-0.8.1.ebuild,v 1.4 2011/09/14 16:58:32 ssuominen Exp $
EAPI=2
-inherit games
+inherit eutils games
DESCRIPTION="MSX emulator that aims for perfection"
HOMEPAGE="http://openmsx.sourceforge.net/"
@@ -24,6 +24,8 @@ DEPEND="dev-lang/tcl
virtual/opengl"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng15.patch
+
sed -i \
-e '/^LDFLAGS:=/d' \
-e '/LINK_FLAGS_PREFIX/d' \