summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2015-01-18 11:32:28 +0000
committerAlfredo Tupone <tupone@gentoo.org>2015-01-18 11:32:28 +0000
commite8c926b49d736f51ade1fc9f74fd38531e487b08 (patch)
tree44356296fd07937efc6acf7da2d28fba052d5236 /games-emulation/openmsx
parentsci-libs/scikits_image: Add missing dep, #536880 (diff)
downloadgentoo-2-e8c926b49d736f51ade1fc9f74fd38531e487b08.tar.gz
gentoo-2-e8c926b49d736f51ade1fc9f74fd38531e487b08.tar.bz2
gentoo-2-e8c926b49d736f51ade1fc9f74fd38531e487b08.zip
Verbose build. Bug #444276
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-emulation/openmsx')
-rw-r--r--games-emulation/openmsx/ChangeLog6
-rw-r--r--games-emulation/openmsx/files/openmsx-0.9.1-verbose.patch14
-rw-r--r--games-emulation/openmsx/openmsx-0.9.1.ebuild3
3 files changed, 21 insertions, 2 deletions
diff --git a/games-emulation/openmsx/ChangeLog b/games-emulation/openmsx/ChangeLog
index fe91506461e0..2c2bc8d790f7 100644
--- a/games-emulation/openmsx/ChangeLog
+++ b/games-emulation/openmsx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/openmsx
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/ChangeLog,v 1.50 2015/01/17 16:43:57 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/ChangeLog,v 1.51 2015/01/18 11:32:28 tupone Exp $
+
+ 18 Jan 2015; Tupone Alfredo <tupone@gentoo.org> openmsx-0.9.1.ebuild,
+ +files/openmsx-0.9.1-verbose.patch:
+ Verbose build. Bug #444276 by Agostino Sarubbo
17 Jan 2015; Tupone Alfredo <tupone@gentoo.org> openmsx-0.9.1.ebuild:
EAPI 5
diff --git a/games-emulation/openmsx/files/openmsx-0.9.1-verbose.patch b/games-emulation/openmsx/files/openmsx-0.9.1-verbose.patch
new file mode 100644
index 000000000000..18ac6fdc83b6
--- /dev/null
+++ b/games-emulation/openmsx/files/openmsx-0.9.1-verbose.patch
@@ -0,0 +1,14 @@
+--- build/main.mk.old 2015-01-18 12:18:50.608153217 +0100
++++ build/main.mk 2015-01-18 12:20:00.352861984 +0100
+@@ -541,10 +541,9 @@
+ DEPEND_SUBST=$(patsubst $(SOURCES_PATH)/%.cc,$(DEPEND_PATH)/%.d,$<)
+ $(OBJECTS_FULL): $(INIT_DUMMY_FILE)
+ $(OBJECTS_FULL): $(OBJECTS_PATH)/%.o: $(SOURCES_PATH)/%.cc $(DEPEND_PATH)/%.d
+- @echo "Compiling $(patsubst $(SOURCES_PATH)/%,%,$<)..."
+ @mkdir -p $(@D)
+ @mkdir -p $(patsubst $(OBJECTS_PATH)%,$(DEPEND_PATH)%,$(@D))
+- @$(COMPILE_ENV) $(CXX) \
++ $(COMPILE_ENV) $(CXX) \
+ $(DEPEND_FLAGS) -MMD -MF $(DEPEND_SUBST) \
+ -o $@ $(CXXFLAGS) $(COMPILE_FLAGS) -c $<
+ @touch $@ # Force .o file to be newer than .d file.
diff --git a/games-emulation/openmsx/openmsx-0.9.1.ebuild b/games-emulation/openmsx/openmsx-0.9.1.ebuild
index f6ce679fff86..1394c8142c21 100644
--- a/games-emulation/openmsx/openmsx-0.9.1.ebuild
+++ b/games-emulation/openmsx/openmsx-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/openmsx-0.9.1.ebuild,v 1.6 2015/01/17 16:43:57 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/openmsx-0.9.1.ebuild,v 1.7 2015/01/18 11:32:28 tupone Exp $
EAPI=5
inherit eutils games
@@ -34,6 +34,7 @@ src_prepare() {
|| die
sed -i -e '/SYMLINK/s:true:false:' build/custom.mk || die
sed -i -e 's/GPL.txt//' doc/node.mk || die
+ epatch "${FILESDIR}"/${P}-verbose.patch
}
src_compile() {