summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-18 21:42:04 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-18 21:42:04 +0000
commit763e703bbce2c93a16b70cf296bb805e7b98b92f (patch)
tree3ccc6256154f2e1bddcd20c474daf8ea8e05dbb2 /games-emulation
parentAdd Version 3.5.1, fixes Bug 54241 (Manifest recommit) (diff)
downloadgentoo-2-763e703bbce2c93a16b70cf296bb805e7b98b92f.tar.gz
gentoo-2-763e703bbce2c93a16b70cf296bb805e7b98b92f.tar.bz2
gentoo-2-763e703bbce2c93a16b70cf296bb805e7b98b92f.zip
amd64 compile fix for bug #54270 - thanks to Andrew Williams
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/xmame/ChangeLog5
-rw-r--r--games-emulation/xmame/xmame-0.83.1.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/games-emulation/xmame/ChangeLog b/games-emulation/xmame/ChangeLog
index b818fe4c282f..dd8d9ff56f77 100644
--- a/games-emulation/xmame/ChangeLog
+++ b/games-emulation/xmame/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/xmame
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.21 2004/06/16 03:40:37 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.22 2004/06/18 21:42:04 mr_bones_ Exp $
+
+ 18 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> xmame-0.83.1.ebuild:
+ amd64 compile fix for bug #54270 - thanks to Andrew Williams
*xmame-0.83.1 (15 Jun 2004)
diff --git a/games-emulation/xmame/xmame-0.83.1.ebuild b/games-emulation/xmame/xmame-0.83.1.ebuild
index 962ca2f90f34..9c2648f0aa2a 100644
--- a/games-emulation/xmame/xmame-0.83.1.ebuild
+++ b/games-emulation/xmame/xmame-0.83.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.83.1.ebuild,v 1.1 2004/06/16 03:40:37 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.83.1.ebuild,v 1.2 2004/06/18 21:42:04 mr_bones_ Exp $
inherit flag-o-matic gcc eutils games
@@ -133,11 +133,14 @@ src_unpack() {
fi
case ${ARCH} in
- x86|ia64|amd64) append-flags -Wno-unused -fomit-frame-pointer -fstrict-aliasing -fstrength-reduce -ffast-math
+ x86|ia64) append-flags -Wno-unused -fomit-frame-pointer -fstrict-aliasing -fstrength-reduce -ffast-math
[ $(gcc-major-version) -eq 3 ] \
&& append-flags -falign-functions=2 -falign-jumps=2 -falign-loops=2 \
|| append-flags -malign-functions=2 -malign-jumps=2 -malign-loops=2
;;
+ # amd64 no likey the -ffast-math - bug #54270
+ amd64) append-flags -Wno-unused -fomit-frame-pointer -fstrict-aliasing -fstrength-reduce
+ ;;
ppc) append-flags -Wno-unused -funroll-loops -fstrength-reduce -fomit-frame-pointer -ffast-math -fsigned-char
;;
hppa) append-flags -ffunction-sections