summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-21 06:02:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-21 06:02:59 +0000
commitcc6889b0a355d225487c03077d09604ac489fe62 (patch)
tree55b2fd335ea9d6d5553598342df09c9a2b80a801 /games-emulation
parentdont need glibc (diff)
downloadgentoo-2-cc6889b0a355d225487c03077d09604ac489fe62.tar.gz
gentoo-2-cc6889b0a355d225487c03077d09604ac489fe62.tar.bz2
gentoo-2-cc6889b0a355d225487c03077d09604ac489fe62.zip
update glx-fix.patch for 0.81.1 (bug #48470)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/xmame/ChangeLog6
-rw-r--r--games-emulation/xmame/files/0.81.1-glx-fix.patch11
-rw-r--r--games-emulation/xmame/xmame-0.81.1.ebuild5
3 files changed, 19 insertions, 3 deletions
diff --git a/games-emulation/xmame/ChangeLog b/games-emulation/xmame/ChangeLog
index 2ca1a7b43cd4..77291fd70040 100644
--- a/games-emulation/xmame/ChangeLog
+++ b/games-emulation/xmame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/xmame
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.17 2004/04/19 10:31:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.18 2004/04/21 06:02:59 mr_bones_ Exp $
+
+ 20 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> xmame-0.81.1.ebuild,
+ files/0.81.1-glx-fix.patch:
+ update glx-fix.patch for 0.81.1 (bug #48470)
*xmame-0.81.1 (19 Apr 2004)
diff --git a/games-emulation/xmame/files/0.81.1-glx-fix.patch b/games-emulation/xmame/files/0.81.1-glx-fix.patch
new file mode 100644
index 000000000000..cbcb32d8a7dc
--- /dev/null
+++ b/games-emulation/xmame/files/0.81.1-glx-fix.patch
@@ -0,0 +1,11 @@
+--- src/unix/osd_cpu.h.orig 2004-04-20 14:30:49.000000000 -0700
++++ src/unix/osd_cpu.h 2004-04-20 14:31:48.000000000 -0700
+@@ -38,7 +38,7 @@
+ #endif
+ #endif
+
+-#ifndef __ARCH_solaris
++#if !defined __ARCH_solaris && !defined xgl
+ /* grrr work around some stupid header conflicts */
+ #if !defined __XF86_DGA_C && !defined __XOPENGL_C_ && !defined LONG64
+ typedef signed char INT8;
diff --git a/games-emulation/xmame/xmame-0.81.1.ebuild b/games-emulation/xmame/xmame-0.81.1.ebuild
index a1655ff9af80..ad991b66a7cf 100644
--- a/games-emulation/xmame/xmame-0.81.1.ebuild
+++ b/games-emulation/xmame/xmame-0.81.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.81.1.ebuild,v 1.1 2004/04/19 10:31:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.81.1.ebuild,v 1.2 2004/04/21 06:02:59 mr_bones_ Exp $
-inherit games flag-o-matic gcc eutils
+inherit flag-o-matic gcc eutils games
TARGET="${PN}"
@@ -36,6 +36,7 @@ S="${WORKDIR}/xmame-${PV}"
src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/${PV}-glx-fix.patch
sed -i \
-e 's:JOY_BUTTONS 16:JOY_BUTTONS 32:' src/unix/devices.h \
|| die "setting joybuttons failed" #36818