summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-02-23 00:29:31 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-02-23 00:29:31 +0000
commit895cc17bf8b5118c44aa2575b37ecd5ee11754bb (patch)
treec3598e11966db3902d1bfd36af8389c8f9021ca6 /games-fps/ut2004-bonuspack-ece
parentAdd a simple cron job for scanning for failed harddrives #82942 by Guilherme ... (diff)
downloadgentoo-2-895cc17bf8b5118c44aa2575b37ecd5ee11754bb.tar.gz
gentoo-2-895cc17bf8b5118c44aa2575b37ecd5ee11754bb.tar.bz2
gentoo-2-895cc17bf8b5118c44aa2575b37ecd5ee11754bb.zip
Initial import of new broken-up ut2004 install.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'games-fps/ut2004-bonuspack-ece')
-rw-r--r--games-fps/ut2004-bonuspack-ece/ChangeLog10
-rw-r--r--games-fps/ut2004-bonuspack-ece/files/digest-ut2004-bonuspack-ece-11
-rw-r--r--games-fps/ut2004-bonuspack-ece/metadata.xml9
-rw-r--r--games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1.ebuild61
4 files changed, 81 insertions, 0 deletions
diff --git a/games-fps/ut2004-bonuspack-ece/ChangeLog b/games-fps/ut2004-bonuspack-ece/ChangeLog
new file mode 100644
index 000000000000..6691a9907384
--- /dev/null
+++ b/games-fps/ut2004-bonuspack-ece/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-fps/ut2004-bonuspack-ece
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-bonuspack-ece/ChangeLog,v 1.1 2005/02/23 00:29:31 wolf31o2 Exp $
+
+*ut2004-bonuspack-ece-1 (22 Feb 2005)
+
+ 22 Feb 2005; Chris Gianelloni <wolf31o2@gentoo.org> +metadata.xml,
+ +ut2004-bonuspack-ece-1.ebuild:
+ Initial import of new broken-up ut2004 install.
+
diff --git a/games-fps/ut2004-bonuspack-ece/files/digest-ut2004-bonuspack-ece-1 b/games-fps/ut2004-bonuspack-ece/files/digest-ut2004-bonuspack-ece-1
new file mode 100644
index 000000000000..795cc7ecacf2
--- /dev/null
+++ b/games-fps/ut2004-bonuspack-ece/files/digest-ut2004-bonuspack-ece-1
@@ -0,0 +1 @@
+MD5 b687d747d199c6c70bb38fceaa8f666c ut2004-ecebonuspack.tar.bz2 77120293
diff --git a/games-fps/ut2004-bonuspack-ece/metadata.xml b/games-fps/ut2004-bonuspack-ece/metadata.xml
new file mode 100644
index 000000000000..fe08918e6837
--- /dev/null
+++ b/games-fps/ut2004-bonuspack-ece/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>wolf31o2@gentoo.org</email>
+ <name>Chris Gianelloni</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1.ebuild b/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1.ebuild
new file mode 100644
index 000000000000..7c9d96934fa0
--- /dev/null
+++ b/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1.ebuild,v 1.1 2005/02/23 00:29:31 wolf31o2 Exp $
+
+inherit games games-ut2k4mod
+
+MY_P="ut2004-ecebonuspack.tar.bz2"
+DESCRIPTION="Unreal Tournament 2004 - Editor's Choice Edition bonus pack"
+HOMEPAGE="http://www.unrealtournament2004.com/"
+SRC_URI="mirror://3dgamers/pub/3dgamers7/games/unrealtourn2k4/Missions/${MY_P}
+ mirror://3dgamers/pub/3dgamers/games/unrealtourn2k4/Missions/${MY_P}"
+
+LICENSE="ut2003"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+RESTRICT="nostrip nomirror"
+IUSE=""
+
+
+RDEPEND="games-fps/ut2004-data"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/ut2004-ECEBonusPack
+
+dir=${GAMES_PREFIX_OPT}/ut2004
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ check_dvd
+
+ if [[ ! ${USE_ECE_DVD} -eq 1 ]]
+ then
+ games_pkg_setup
+ fi
+}
+
+src_unpack() {
+ if [[ ! ${USE_ECE_DVD} -eq 1 ]]
+ then
+ unpack ${A}
+ fi
+}
+
+src_install() {
+ if [[ ! ${USE_ECE_DVD} -eq 1 ]]
+ then
+ # Installing Editor's Choice Edition
+ for n in {Animations,Help,Manual,Maps,Sounds,StaticMeshes,System,Textures}
+ do
+ dodir ${dir}/${n}
+ cp -r ${S}/${n}/* ${Ddir}/${n} \
+ || die "copying ${n} from Editor's Choice Edition"
+ done
+
+ prepgamesdirs
+ fi
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+}