summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-13 04:51:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-13 04:51:38 +0000
commit98f1ee4365bbb3040c39f13dfd6f696247ec2fd4 (patch)
treeb0a52275537100709fb1299f5cf7975be5b96434 /games-rpg/daimonin-client
parentversion bump (diff)
downloadgentoo-2-98f1ee4365bbb3040c39f13dfd6f696247ec2fd4.tar.gz
gentoo-2-98f1ee4365bbb3040c39f13dfd6f696247ec2fd4.tar.bz2
gentoo-2-98f1ee4365bbb3040c39f13dfd6f696247ec2fd4.zip
version bump
(Portage version: 2.1.6.4/cvs/Linux 2.6.27.8 i686)
Diffstat (limited to 'games-rpg/daimonin-client')
-rw-r--r--games-rpg/daimonin-client/ChangeLog8
-rw-r--r--games-rpg/daimonin-client/daimonin-client-0.9.7.1.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/games-rpg/daimonin-client/ChangeLog b/games-rpg/daimonin-client/ChangeLog
index e4b1c7611467..021d065e81f5 100644
--- a/games-rpg/daimonin-client/ChangeLog
+++ b/games-rpg/daimonin-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/daimonin-client
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/ChangeLog,v 1.19 2009/01/13 02:34:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/ChangeLog,v 1.20 2009/01/13 04:51:38 mr_bones_ Exp $
+
+*daimonin-client-0.9.7.1 (13 Jan 2009)
+
+ 13 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +daimonin-client-0.9.7.1.ebuild:
+ version bump
13 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
daimonin-client-0.9.7.ebuild:
diff --git a/games-rpg/daimonin-client/daimonin-client-0.9.7.1.ebuild b/games-rpg/daimonin-client/daimonin-client-0.9.7.1.ebuild
new file mode 100644
index 000000000000..26935c7b76a7
--- /dev/null
+++ b/games-rpg/daimonin-client/daimonin-client-0.9.7.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/daimonin-client-0.9.7.1.ebuild,v 1.1 2009/01/13 04:51:38 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="a graphical 2D tile-based MMORPG"
+HOMEPAGE="http://daimonin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/daimonin/${MY_P}.zip
+ mirror://sourceforge/daimonin/AllMusic.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[png]
+ dev-games/physfs
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/daimonin/client/make/linux
+
+src_unpack() {
+ unpack ${MY_P}.zip
+ cd daimonin/client/media
+ rm -f *
+ unpack AllMusic.zip
+}
+
+src_prepare() {
+ sed -i \
+ -e 's:$(d_datadir):$(DESTDIR)$(d_datadir):' \
+ -e '/PROGRAMS/s:daimonin-updater::' \
+ -e '/\/tools/d' \
+ Makefile.in \
+ || die "sed failed"
+ chmod +x configure
+}
+
+src_configure() {
+ egamesconf --disable-simplelayout
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd ../..
+ dodoc README*
+ newicon skins/subred/bitmaps/pentagram.png ${PN}.png || die "newicon failed"
+ make_desktop_entry daimonin Daimonin
+ prepgamesdirs
+}