summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-03-12 19:44:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-03-12 19:44:08 +0000
commit159685f18840cb566e0df18a5b1fcc495ad5a415 (patch)
tree42a5ce324005d27a65a546ab6f6a2ee5727348c5 /games-server
parentarm stable, bug #405219 (diff)
downloadgentoo-2-159685f18840cb566e0df18a5b1fcc495ad5a415.tar.gz
gentoo-2-159685f18840cb566e0df18a5b1fcc495ad5a415.tar.bz2
gentoo-2-159685f18840cb566e0df18a5b1fcc495ad5a415.zip
version bump
(Portage version: 2.1.10.44/cvs/Linux i686)
Diffstat (limited to 'games-server')
-rw-r--r--games-server/crossfire-server/ChangeLog10
-rw-r--r--games-server/crossfire-server/crossfire-server-1.60.0.ebuild39
-rw-r--r--games-server/crossfire-server/files/crossfire-server-1.60.0-curl.patch10
3 files changed, 57 insertions, 2 deletions
diff --git a/games-server/crossfire-server/ChangeLog b/games-server/crossfire-server/ChangeLog
index 425d1d814295..0abf21c24eaa 100644
--- a/games-server/crossfire-server/ChangeLog
+++ b/games-server/crossfire-server/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-server/crossfire-server
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/crossfire-server/ChangeLog,v 1.19 2011/10/10 14:40:21 tupone Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/crossfire-server/ChangeLog,v 1.20 2012/03/12 19:44:08 mr_bones_ Exp $
+
+*crossfire-server-1.60.0 (12 Mar 2012)
+
+ 12 Mar 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +crossfire-server-1.60.0.ebuild, +files/crossfire-server-1.60.0-curl.patch:
+ version bump
10 Oct 2011; Tupone Alfredo <tupone@gentoo.org>
crossfire-server-1.11.0.ebuild, +files/crossfire-server-1.11.0-curl.patch:
diff --git a/games-server/crossfire-server/crossfire-server-1.60.0.ebuild b/games-server/crossfire-server/crossfire-server-1.60.0.ebuild
new file mode 100644
index 000000000000..677af6094028
--- /dev/null
+++ b/games-server/crossfire-server/crossfire-server-1.60.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/crossfire-server/crossfire-server-1.60.0.ebuild,v 1.1 2012/03/12 19:44:08 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils autotools games
+
+MY_P="${P/-server/}"
+DESCRIPTION="server for the crossfire clients"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${MY_P}.tar.gz
+ mirror://sourceforge/crossfire/crossfire-${PV}.maps.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X"
+
+DEPEND="
+ net-misc/curl
+ X? (
+ x11-libs/libXaw
+ media-libs/libpng )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ rm -f "${WORKDIR}"/maps/Info/combine.pl # bug #236205
+ epatch "${FILESDIR}"/${P}-curl.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ keepdir "${GAMES_STATEDIR}"/crossfire/{datafiles,maps,players,template-maps,unique-items}
+ dodoc AUTHORS ChangeLog DEVELOPERS NEWS README TODO
+ insinto "${GAMES_DATADIR}/crossfire"
+ doins -r "${WORKDIR}/maps" || die
+ prepgamesdirs
+}
diff --git a/games-server/crossfire-server/files/crossfire-server-1.60.0-curl.patch b/games-server/crossfire-server/files/crossfire-server-1.60.0-curl.patch
new file mode 100644
index 000000000000..86365d2ee85b
--- /dev/null
+++ b/games-server/crossfire-server/files/crossfire-server-1.60.0-curl.patch
@@ -0,0 +1,10 @@
+--- socket/metaserver.c.old 2011-10-10 16:23:40.513409319 +0200
++++ socket/metaserver.c 2011-10-10 16:23:46.617408594 +0200
+@@ -48,7 +48,6 @@
+
+ #ifdef HAVE_CURL_CURL_H
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+ #endif
+