summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-09-19 10:14:48 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-09-19 10:14:48 +0000
commit7d9ff02586f577d76b25d960ea8aae9d554e2a76 (patch)
tree10ee1a35a9b006cd0e0196acbac0f1f006841d60 /games-simulation
parentRemove RDEPENDs on browser stuff (diff)
downloadgentoo-2-7d9ff02586f577d76b25d960ea8aae9d554e2a76.tar.gz
gentoo-2-7d9ff02586f577d76b25d960ea8aae9d554e2a76.tar.bz2
gentoo-2-7d9ff02586f577d76b25d960ea8aae9d554e2a76.zip
Fix compilation with gcc-4.3. Bug #232917
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/fgrun/ChangeLog6
-rw-r--r--games-simulation/fgrun/fgrun-1.0.0.ebuild6
-rw-r--r--games-simulation/fgrun/files/fgrun-1.0.0-gcc43.patch20
3 files changed, 28 insertions, 4 deletions
diff --git a/games-simulation/fgrun/ChangeLog b/games-simulation/fgrun/ChangeLog
index cfbe4f8739f1..14fa74ce91e8 100644
--- a/games-simulation/fgrun/ChangeLog
+++ b/games-simulation/fgrun/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/fgrun
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/ChangeLog,v 1.3 2008/01/01 18:58:16 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/ChangeLog,v 1.4 2008/09/19 10:14:47 tupone Exp $
+
+ 19 Sep 2008; Tupone Alfredo <tupone@gentoo.org>
+ +files/fgrun-1.0.0-gcc43.patch, fgrun-1.0.0.ebuild:
+ Fix compilation with gcc-4.3. Bug #232917 by Florian Streibelt
*fgrun-1.0.0 (01 Jan 2008)
diff --git a/games-simulation/fgrun/fgrun-1.0.0.ebuild b/games-simulation/fgrun/fgrun-1.0.0.ebuild
index bd698d3c71ae..47a4868ae52d 100644
--- a/games-simulation/fgrun/fgrun-1.0.0.ebuild
+++ b/games-simulation/fgrun/fgrun-1.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/fgrun-1.0.0.ebuild,v 1.1 2008/01/01 18:58:16 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/fgrun-1.0.0.ebuild,v 1.2 2008/09/19 10:14:47 tupone Exp $
inherit autotools eutils multilib games
@@ -22,7 +22,7 @@ DEPEND="dev-games/simgear
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}"-fltk.patch
+ epatch "${FILESDIR}/${P}"-{fltk,gcc43}.patch
AT_M4DIR=. eautoreconf
}
diff --git a/games-simulation/fgrun/files/fgrun-1.0.0-gcc43.patch b/games-simulation/fgrun/files/fgrun-1.0.0-gcc43.patch
new file mode 100644
index 000000000000..0d7fa1a7509d
--- /dev/null
+++ b/games-simulation/fgrun/files/fgrun-1.0.0-gcc43.patch
@@ -0,0 +1,20 @@
+--- src/advanced.cxx.old 2008-09-19 12:01:50.000000000 +0200
++++ src/advanced.cxx 2008-09-19 12:02:17.000000000 +0200
+@@ -3,6 +3,7 @@
+ #if HAVE_CONFIG_H
+ #include <config.h>
+ #endif
++#include <string.h>
+ #include "advanced.h"
+
+ void Advanced::cb_page_list_i(Fl_Browser* o, void*) {
+--- src/settings.cxx.old 2008-09-19 12:03:55.000000000 +0200
++++ src/settings.cxx 2008-09-19 12:04:19.000000000 +0200
+@@ -25,6 +25,7 @@
+ #endif
+
+ #include <string>
++#include <string.h>
+
+ #include <FL/filename.H>
+