summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-06-17 21:54:13 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-06-17 21:54:13 +0000
commit700754896f8f308fb619e20ab8dd753d6f898e6c (patch)
tree19ca6b73e7c835cca14aa53795e4172ba5e8f5c7 /games-sports/xmoto
parent* double bump (diff)
downloadgentoo-2-700754896f8f308fb619e20ab8dd753d6f898e6c.tar.gz
gentoo-2-700754896f8f308fb619e20ab8dd753d6f898e6c.tar.bz2
gentoo-2-700754896f8f308fb619e20ab8dd753d6f898e6c.zip
version bump
(Portage version: 2.1.2.9)
Diffstat (limited to 'games-sports/xmoto')
-rw-r--r--games-sports/xmoto/ChangeLog7
-rw-r--r--games-sports/xmoto/files/digest-xmoto-0.3.06
-rw-r--r--games-sports/xmoto/xmoto-0.3.0.ebuild74
3 files changed, 86 insertions, 1 deletions
diff --git a/games-sports/xmoto/ChangeLog b/games-sports/xmoto/ChangeLog
index aa24676e3ea1..d3cf178d1f30 100644
--- a/games-sports/xmoto/ChangeLog
+++ b/games-sports/xmoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-sports/xmoto
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.14 2007/04/23 12:23:40 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.15 2007/06/17 21:54:13 genstef Exp $
+
+*xmoto-0.3.0 (17 Jun 2007)
+
+ 17 Jun 2007; Stefan Schweizer <genstef@gentoo.org> +xmoto-0.3.0.ebuild:
+ version bump
23 Apr 2007; Tristan Heaven <nyhm@gentoo.org> xmoto-0.2.7.ebuild:
Fix collision with media-gfx/inkscape
diff --git a/games-sports/xmoto/files/digest-xmoto-0.3.0 b/games-sports/xmoto/files/digest-xmoto-0.3.0
new file mode 100644
index 000000000000..5d1009dd5b34
--- /dev/null
+++ b/games-sports/xmoto/files/digest-xmoto-0.3.0
@@ -0,0 +1,6 @@
+MD5 fce995d497841ef4f51ebbf3f6e510cc svg2lvl-0.3.0.tar.gz 40660
+RMD160 4cc783c0388e39429062540324e86599f9d950f5 svg2lvl-0.3.0.tar.gz 40660
+SHA256 2e63ca642075bee4e685a55e560533aac2b9ac9606eafa8262b6cf8207138f50 svg2lvl-0.3.0.tar.gz 40660
+MD5 f3bf2d322ea82576ea1aec38694490fe xmoto-0.3.0-src.tar.gz 13588369
+RMD160 605ee9b8997dfb1df9f66f5f859a8e794b3e2e27 xmoto-0.3.0-src.tar.gz 13588369
+SHA256 9f31c4473e2b1958d095d227652f54a4cfd306a11fca812800e7939417591dc5 xmoto-0.3.0-src.tar.gz 13588369
diff --git a/games-sports/xmoto/xmoto-0.3.0.ebuild b/games-sports/xmoto/xmoto-0.3.0.ebuild
new file mode 100644
index 000000000000..c01f863bc76c
--- /dev/null
+++ b/games-sports/xmoto/xmoto-0.3.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/xmoto-0.3.0.ebuild,v 1.1 2007/06/17 21:54:13 genstef Exp $
+
+inherit eutils games
+
+LVL="svg2lvl-0.3.0"
+DESCRIPTION="A challenging 2D motocross platform game"
+HOMEPAGE="http://xmoto.tuxfamily.org"
+SRC_URI="http://download.tuxfamily.org/${PN}/${PN}/${PV}/${P}-src.tar.gz
+ editor? ( mirror://sourceforge/${PN}/${LVL}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls editor"
+
+RDEPEND="media-libs/jpeg
+ media-libs/libpng
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ net-misc/curl
+ dev-lang/lua
+ dev-games/ode
+ virtual/opengl
+ virtual/glu
+ nls? ( virtual/libintl )
+ editor? ( >=media-gfx/inkscape-0.45 )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:$(localedir):/usr/share/locale:' po/Makefile.in.in \
+ || die "sed Makefile.in.in failed"
+ use editor && rm -f "${WORKDIR}"/${LVL}/{bezmisc,inkex}.py
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-localesdir=/usr/share/locale \
+ $(use_enable nls) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README TODO ChangeLog
+
+ doicon extra/xmoto.xpm
+ domenu extra/xmoto.desktop
+
+ prepgamesdirs
+
+ if use editor; then
+ insinto /usr/share/inkscape/extensions
+ doins "${WORKDIR}"/${LVL}/*.{inx,py,xml} || die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if use editor; then
+ elog "If you want to know how to create Xmoto levels"
+ elog "have a look at this Tutorial:"
+ elog "http://wiki.xmoto.free.fr/index.php?title=Inkscape-0.3.0#Tutorial"
+ elog "You can share your levels on the Xmoto homepage."
+ fi
+}