summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-04-04 20:51:56 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-04-04 20:51:56 +0000
commit4aab710c10364d299c48313a5d57183bccf9ef52 (patch)
tree6f14023dc8e819f00efc03ff93a294226fa6c3e2 /games-strategy
parentStable on sparc and stick back ~sparc too (diff)
downloadgentoo-2-4aab710c10364d299c48313a5d57183bccf9ef52.tar.gz
gentoo-2-4aab710c10364d299c48313a5d57183bccf9ef52.tar.bz2
gentoo-2-4aab710c10364d299c48313a5d57183bccf9ef52.zip
use games_get_libdir
(Portage version: 2.1.2.3)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/castle-combat/castle-combat-0.8.1.ebuild30
1 files changed, 16 insertions, 14 deletions
diff --git a/games-strategy/castle-combat/castle-combat-0.8.1.ebuild b/games-strategy/castle-combat/castle-combat-0.8.1.ebuild
index 4b6e972a150a..6d1f5e1ebb1d 100644
--- a/games-strategy/castle-combat/castle-combat-0.8.1.ebuild
+++ b/games-strategy/castle-combat/castle-combat-0.8.1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/castle-combat/castle-combat-0.8.1.ebuild,v 1.1 2006/07/29 23:05:56 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/castle-combat/castle-combat-0.8.1.ebuild,v 1.2 2007/04/04 20:51:56 nyhm Exp $
-inherit games
+inherit eutils games
DESCRIPTION="A clone of the old arcade game Rampart"
HOMEPAGE="http://www.linux-games.com/castle-combat/"
-SRC_URI="mirror://sourceforge/castle-combat/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -19,19 +19,21 @@ DEPEND="dev-python/twisted
src_unpack() {
unpack ${A}
cd "${S}"
- sed -i -e "s:src:${GAMES_LIBDIR}/${PN}:" \
- castle-combat.py
- sed -i -e "/data_path =/s:\"data:\"${GAMES_DATADIR}/${PN}:" \
- src/common.py
+ sed -i "s:src:$(games_get_libdir)/${PN}:" ${PN}.py \
+ || die "sed ${PN}.py failed"
+ sed -i "/data_path =/s:\"data:\"${GAMES_DATADIR}/${PN}:" src/common.py \
+ || die "sed common.py failed"
}
src_install() {
- newgamesbin castle-combat.py castle-combat
- insinto ${GAMES_LIBDIR}/${PN}
- doins src/*
- insinto ${GAMES_DATADIR}/${PN}
- doins -r data/{colourba.ttf,gfx,sound}
- dohtml -r data/font_read_me.html data/doc
+ newgamesbin ${PN}.py ${PN} || die "newgamesbin failed"
+ insinto "$(games_get_libdir)"/${PN}
+ doins src/* || die "doins src failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/{colourba.ttf,gfx,sound} || die "doins data failed"
+ newicon data/gfx/castle.png ${PN}.png
+ make_desktop_entry ${PN} Castle-Combat
+ dohtml data/font_read_me.html data/doc/rules.html
dodoc TODO
prepgamesdirs
}