summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-04-08 22:46:10 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-04-08 22:46:10 +0000
commit630edf323ed4e7f7d999426916d7695465cad115 (patch)
tree10d4cf51af76770abd4a0dfb4e3176f8ea84c9a7 /games-strategy
parentAdd systemd service unit for bug 546004. (diff)
downloadgentoo-2-630edf323ed4e7f7d999426916d7695465cad115.tar.gz
gentoo-2-630edf323ed4e7f7d999426916d7695465cad115.tar.bz2
gentoo-2-630edf323ed4e7f7d999426916d7695465cad115.zip
old
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog5
-rw-r--r--games-strategy/wesnoth/wesnoth-1.10.7.ebuild130
2 files changed, 4 insertions, 131 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 3cc2a3f740e3..afc42c988314 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.242 2015/02/25 16:01:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.243 2015/04/08 22:46:10 mr_bones_ Exp $
+
+ 08 Apr 2015; Michael Sterrett <mr_bones_@gentoo.org> -wesnoth-1.10.7.ebuild:
+ old
25 Feb 2015; Agostino Sarubbo <ago@gentoo.org> wesnoth-1.12.1.ebuild:
Stable for x86, wrt bug #541106
diff --git a/games-strategy/wesnoth/wesnoth-1.10.7.ebuild b/games-strategy/wesnoth/wesnoth-1.10.7.ebuild
deleted file mode 100644
index 8b85bc924c6c..000000000000
--- a/games-strategy/wesnoth/wesnoth-1.10.7.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.10.7.ebuild,v 1.7 2013/12/24 12:47:50 ago Exp $
-
-EAPI=5
-inherit cmake-utils eutils multilib toolchain-funcs flag-o-matic games
-
-DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
-HOMEPAGE="http://www.wesnoth.org/"
-SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
-IUSE="dbus dedicated doc nls server"
-
-RDEPEND=">=media-libs/libsdl-1.2.7:0[joystick,video,X]
- media-libs/sdl-net
- !dedicated? (
- >=media-libs/sdl-ttf-2.0.8
- >=media-libs/sdl-mixer-1.2[vorbis]
- >=media-libs/sdl-image-1.2[jpeg,png]
- dbus? ( sys-apps/dbus )
- sys-libs/zlib
- x11-libs/pango
- dev-lang/lua
- media-libs/fontconfig
- )
- >=dev-libs/boost-1.36
- virtual/libintl"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/gettext"
-
-src_prepare() {
- if use dedicated || use server ; then
- sed \
- -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
- -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
- -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
- -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
- > "${T}"/wesnothd || die
- fi
- if ! use doc ; then
- sed -i \
- -e '/manual/d' \
- doc/CMakeLists.txt || die
- fi
- # how do I hate boost? Let me count the ways...
- local boost_ver=$(best_version ">=dev-libs/boost-1.36")
-
- boost_ver=${boost_ver/*boost-/}
- boost_ver=${boost_ver%.*}
- boost_ver=${boost_ver/./_}
-
- einfo "Using boost version ${boost_ver}"
- append-cxxflags \
- -I/usr/include/boost-${boost_ver}
- append-ldflags \
- -L/usr/$(get_libdir)/boost-${boost_ver}
- export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
- export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
-
- # bug #472994
- mv icons/wesnoth-icon-Mac.png icons/wesnoth-icon.png || die
- mv icons/map-editor-icon-Mac.png icons/wesnoth_editor-icon.png || die
-
- # respect LINGUAS (bug #483316)
- if [[ ${LINGUAS+set} ]] ; then
- local langs
- for lang in $(cat po/LINGUAS)
- do
- has $lang $LINGUAS && langs+="$lang "
- done
- echo "$langs" > po/LINGUAS || die
- fi
-}
-
-src_configure() {
- filter-flags -ftracer -fomit-frame-pointer
- if [[ $(gcc-major-version) -eq 3 ]] ; then
- filter-flags -fstack-protector
- append-flags -fno-stack-protector
- fi
- if use dedicated || use server ; then
- mycmakeargs=(
- "-DENABLE_CAMPAIGN_SERVER=TRUE"
- "-DENABLE_SERVER=TRUE"
- "-DSERVER_UID=${GAMES_USER_DED}"
- "-DSERVER_GID=${GAMES_GROUP}"
- "-DFIFO_DIR=${GAMES_STATEDIR}/run/wesnothd"
- )
- else
- mycmakeargs=(
- "-DENABLE_CAMPAIGN_SERVER=FALSE"
- "-DENABLE_SERVER=FALSE"
- )
- fi
- mycmakeargs+=(
- $(cmake-utils_use_enable !dedicated GAME)
- $(cmake-utils_use_enable !dedicated ENABLE_DESKTOP_ENTRY)
- $(cmake-utils_use_enable nls NLS)
- $(cmake-utils_use_enable dbus NOTIFICATIONS)
- "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
- "-DENABLE_FRIBIDI=FALSE"
- "-DENABLE_STRICT_COMPILATION=FALSE"
- "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
- "-DDATAROOTDIR=${GAMES_DATADIR}"
- "-DBINDIR=${GAMES_BINDIR}"
- "-DICONDIR=/usr/share/pixmaps"
- "-DDESKTOPDIR=/usr/share/applications"
- "-DLOCALEDIR=/usr/share/locale"
- "-DMANDIR=/usr/share/man"
- "-DDOCDIR=/usr/share/doc/${PF}"
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- DOCS="README changelog players_changelog" cmake-utils_src_install
- if use dedicated || use server; then
- keepdir "${GAMES_STATEDIR}/run/wesnothd"
- doinitd "${T}"/wesnothd || die
- fi
- prepgamesdirs
-}