summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-03-24 18:43:23 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-03-24 18:43:23 +0000
commitfbcb249682155260d7ec18a6d9694fa085ce8867 (patch)
treedf5b9935d7d7604026bf5f49724f0a1c904bbd80 /gnome-base
parentVersion bump, and alpha/x86 stable (diff)
downloadgentoo-2-fbcb249682155260d7ec18a6d9694fa085ce8867.tar.gz
gentoo-2-fbcb249682155260d7ec18a6d9694fa085ce8867.tar.bz2
gentoo-2-fbcb249682155260d7ec18a6d9694fa085ce8867.zip
New version for GNOME-2.22. Features a new shiny clock applet and uses GIO.
(Portage version: 2.1.4.4)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-panel/ChangeLog9
-rw-r--r--gnome-base/gnome-panel/gnome-panel-2.22.0.ebuild80
2 files changed, 88 insertions, 1 deletions
diff --git a/gnome-base/gnome-panel/ChangeLog b/gnome-base/gnome-panel/ChangeLog
index 143cf0689b0f..d88ec421a7f2 100644
--- a/gnome-base/gnome-panel/ChangeLog
+++ b/gnome-base/gnome-panel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/gnome-panel
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-panel/ChangeLog,v 1.245 2008/02/18 22:07:29 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-panel/ChangeLog,v 1.246 2008/03/24 18:43:23 eva Exp $
+
+*gnome-panel-2.22.0 (24 Mar 2008)
+
+ 24 Mar 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-panel-2.22.0.ebuild:
+ New version for GNOME-2.22. Features a new shiny clock applet and uses
+ GIO.
18 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org>
gnome-panel-2.20.3.ebuild:
diff --git a/gnome-base/gnome-panel/gnome-panel-2.22.0.ebuild b/gnome-base/gnome-panel/gnome-panel-2.22.0.ebuild
new file mode 100644
index 000000000000..c6a05253409e
--- /dev/null
+++ b/gnome-base/gnome-panel/gnome-panel-2.22.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-panel/gnome-panel-2.22.0.ebuild,v 1.1 2008/03/24 18:43:23 eva Exp $
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="The GNOME panel"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc eds networkmanager"
+
+RDEPEND=">=gnome-base/gnome-desktop-2.12
+ >=x11-libs/pango-1.15.4
+ >=dev-libs/glib-2.15.6
+ >=x11-libs/gtk+-2.11.3
+ >=dev-libs/libgweather-2.21.2
+ dev-libs/libxml2
+ >=gnome-base/libglade-2.5
+ >=gnome-base/libgnome-2.13
+ >=gnome-base/libgnomeui-2.5.4
+ >=gnome-base/libbonoboui-2.1.1
+ >=gnome-base/orbit-2.4
+ >=x11-libs/libwnck-2.19.5
+ >=gnome-base/gconf-2.6.1
+ >=gnome-base/gnome-menus-2.11.1
+ >=gnome-base/libbonobo-2
+ gnome-base/librsvg
+ >=dev-libs/dbus-glib-0.71
+ >=sys-apps/dbus-1.1.2
+ x11-libs/libXau
+ >=x11-libs/cairo-1.0.0
+ eds? ( >=gnome-extra/evolution-data-server-1.6 )
+ networkmanager? ( net-misc/networkmanager )"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.3.2
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ ~app-text/docbook-xml-dtd-4.1.2
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --disable-polkit
+ --with-in-process-applets=clock,notification-area,wncklet
+ $(use_enable networkmanager network-manager)
+ $(use_enable eds)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # FIXME : uh yeah, this is nice
+ # We should patch in a switch here and send it upstream
+ sed -i 's:--load:-v:' "${S}/gnome-panel/Makefile.in" || die "sed failed"
+}
+
+pkg_postinst() {
+ local entries="/etc/gconf/schemas/panel-default-setup.entries"
+ local gconftool="${ROOT}usr/bin/gconftool-2"
+
+ if [ -e "$entries" ]; then
+ einfo "setting panel gconf defaults..."
+
+ GCONF_CONFIG_SOURCE=$("${gconftool}" --get-default-source)
+
+ "${gconftool}" --direct --config-source \
+ "${GCONF_CONFIG_SOURCE}" --load="${entries}"
+ fi
+
+ # Calling this late so it doesn't process the GConf schemas file we already
+ # took care of.
+ gnome2_pkg_postinst
+}