summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2009-05-26 20:44:32 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2009-05-26 20:44:32 +0000
commiteabf4567965b8a4362fbdd4d4956d6ab8012ac8e (patch)
tree399bae544ee865b793df4acfee9bb533d404eee1 /gnome-extra/fast-user-switch-applet
parentMake sure we actually disable the targets which install useless lib symlinks. (diff)
downloadgentoo-2-eabf4567965b8a4362fbdd4d4956d6ab8012ac8e.tar.gz
gentoo-2-eabf4567965b8a4362fbdd4d4956d6ab8012ac8e.tar.bz2
gentoo-2-eabf4567965b8a4362fbdd4d4956d6ab8012ac8e.zip
Add check for libgnomeui; bug #263367
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/fast-user-switch-applet')
-rw-r--r--gnome-extra/fast-user-switch-applet/ChangeLog7
-rw-r--r--gnome-extra/fast-user-switch-applet/fast-user-switch-applet-2.24.0.ebuild16
-rw-r--r--gnome-extra/fast-user-switch-applet/files/fast-user-switch-applet-2.24.0-libgnomeui.patch13
3 files changed, 33 insertions, 3 deletions
diff --git a/gnome-extra/fast-user-switch-applet/ChangeLog b/gnome-extra/fast-user-switch-applet/ChangeLog
index 64935fa3362b..91b64f20a11b 100644
--- a/gnome-extra/fast-user-switch-applet/ChangeLog
+++ b/gnome-extra/fast-user-switch-applet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/fast-user-switch-applet
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/fast-user-switch-applet/ChangeLog,v 1.70 2009/04/27 14:12:22 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/fast-user-switch-applet/ChangeLog,v 1.71 2009/05/26 20:44:32 dang Exp $
+
+ 26 May 2009; Daniel Gryniewicz <dang@gentoo.org>
+ fast-user-switch-applet-2.24.0.ebuild,
+ +files/fast-user-switch-applet-2.24.0-libgnomeui.patch:
+ Add check for libgnomeui; bug #263367
27 Apr 2009; Jeroen Roovers <jer@gentoo.org>
fast-user-switch-applet-2.24.0:
diff --git a/gnome-extra/fast-user-switch-applet/fast-user-switch-applet-2.24.0.ebuild b/gnome-extra/fast-user-switch-applet/fast-user-switch-applet-2.24.0.ebuild
index 5c980b24e3e9..91f4f13c5704 100644
--- a/gnome-extra/fast-user-switch-applet/fast-user-switch-applet-2.24.0.ebuild
+++ b/gnome-extra/fast-user-switch-applet/fast-user-switch-applet-2.24.0.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/fast-user-switch-applet/fast-user-switch-applet-2.24.0.ebuild,v 1.8 2009/04/27 14:12:22 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/fast-user-switch-applet/fast-user-switch-applet-2.24.0.ebuild,v 1.9 2009/05/26 20:44:32 dang Exp $
-inherit eutils gnome2
+EAPI="2"
+
+inherit eutils gnome2 autotools
DESCRIPTION="Fast User Switching Applet for Gnome Desktop"
HOMEPAGE="http://www.gnome.org/"
@@ -16,6 +18,7 @@ RDEPEND=">=dev-libs/glib-2.16
>=x11-libs/gtk+-2.8
>=gnome-base/gnome-panel-2.0
>=gnome-base/libglade-2.0
+ gnome-base/libgnomeui
gnome-base/gconf
gnome-base/gdm
x11-libs/libXmu
@@ -35,3 +38,12 @@ DOCS="AUTHORS ChangeLog NEWS README"
pkg_setup() {
G2CONF="${G2CONF} --with-gdm-config=/usr/share/gdm/defaults.conf"
}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Need libgnomeui for help display; bug #263367
+ epatch "${FILESDIR}"/${P}-libgnomeui.patch
+
+ eautoreconf
+}
diff --git a/gnome-extra/fast-user-switch-applet/files/fast-user-switch-applet-2.24.0-libgnomeui.patch b/gnome-extra/fast-user-switch-applet/files/fast-user-switch-applet-2.24.0-libgnomeui.patch
new file mode 100644
index 000000000000..03b9dad0f582
--- /dev/null
+++ b/gnome-extra/fast-user-switch-applet/files/fast-user-switch-applet-2.24.0-libgnomeui.patch
@@ -0,0 +1,13 @@
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN fast-user-switch-applet-2.24.0.orig/configure.ac fast-user-switch-applet-2.24.0/configure.ac
+--- fast-user-switch-applet-2.24.0.orig/configure.ac 2008-09-22 09:56:37.000000000 -0400
++++ fast-user-switch-applet-2.24.0/configure.ac 2009-05-26 16:34:29.000000000 -0400
+@@ -51,7 +51,8 @@ GLIB_REQUIRED_VERSION=2.15.3
+ PKG_CHECK_MODULES(APPLET, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ libpanelapplet-2.0 >= $PANEL_REQUIRED_VERSION
+ libglade-2.0 >= $GLADE_REQUIRED_VERSION
+- gio-2.0 >= $GLIB_REQUIRED_VERSION)
++ gio-2.0 >= $GLIB_REQUIRED_VERSION
++ libgnomeui-2.0)
+ AC_SUBST(APPLET_CFLAGS)
+ AC_SUBST(APPLET_LIBS)
+