summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-04-07 22:56:47 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-04-07 22:56:47 +0000
commit29bf8ce7c75772a4902a546a19ffb40c423d019e (patch)
treed3655c62e4a163176cba0397f56634abe820fc8f /gnome-extra/gtkhtml
parentRemoving media-libs/x264-svn because of pkgmove (diff)
downloadgentoo-2-29bf8ce7c75772a4902a546a19ffb40c423d019e.tar.gz
gentoo-2-29bf8ce7c75772a4902a546a19ffb40c423d019e.tar.bz2
gentoo-2-29bf8ce7c75772a4902a546a19ffb40c423d019e.zip
bump to 3.18.1, one bug fix and two translation updates.
(Portage version: 2.1.5_rc1)
Diffstat (limited to 'gnome-extra/gtkhtml')
-rw-r--r--gnome-extra/gtkhtml/ChangeLog8
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-3.18.1.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/gnome-extra/gtkhtml/ChangeLog b/gnome-extra/gtkhtml/ChangeLog
index fd6c6f353809..5639b1581b02 100644
--- a/gnome-extra/gtkhtml/ChangeLog
+++ b/gnome-extra/gtkhtml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/gtkhtml
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/ChangeLog,v 1.154 2008/03/27 10:26:49 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/ChangeLog,v 1.155 2008/04/07 22:56:47 eva Exp $
+
+*gtkhtml-3.18.1 (07 Apr 2008)
+
+ 07 Apr 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +gtkhtml-3.18.1.ebuild:
+ bump to 3.18.1, one bug fix and two translation updates.
27 Mar 2008; Gilles Dartiguelongue <eva@gentoo.org> gtkhtml-2.11.1.ebuild:
fix typo on fbsd conditional, bug #215004
diff --git a/gnome-extra/gtkhtml/gtkhtml-3.18.1.ebuild b/gnome-extra/gtkhtml/gtkhtml-3.18.1.ebuild
new file mode 100644
index 000000000000..9ec97f3d2bc6
--- /dev/null
+++ b/gnome-extra/gtkhtml/gtkhtml-3.18.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/gtkhtml-3.18.1.ebuild,v 1.1 2008/04/07 22:56:47 eva Exp $
+EAPI="1"
+
+inherit gnome2
+
+DESCRIPTION="Lightweight HTML Rendering/Printing/Editing Engine"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="3.14"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="static"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=gnome-base/gail-1.1
+ >=x11-themes/gnome-icon-theme-1.2
+ >=gnome-base/libbonobo-2.20.3
+ >=gnome-base/libbonoboui-2.2.4
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/orbit-2
+ net-libs/libsoup:2.4"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35.5
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ ELTCONF="--reverse-deps"
+ G2CONF="$(use_enable static) --enable-file-chooser"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix deprecated API disabling in used glib library - this is not future-proof, bug 210657
+ sed -i -e '/G_DISABLE_DEPRECATED/d' \
+ "${S}/gtkhtml/Makefile.am" "${S}/gtkhtml/Makefile.in" \
+ "${S}/components/html-editor/Makefile.am" "${S}/components/html-editor/Makefile.in"
+
+ sed -i -e 's:-DGTK_DISABLE_DEPRECATED=1 -DGDK_DISABLE_DEPRECATED=1 -DG_DISABLE_DEPRECATED=1 -DGNOME_DISABLE_DEPRECATED=1::g' \
+ "${S}/a11y/Makefile.am" "${S}/a11y/Makefile.in"
+}